954 dash problems - Honda Motorcycles - FireBlades.org
Electronics Discussion of Motorcycle Related GPS, Audio, Video, Radar Detectors, Lap Timers, Communicators, etc.

User Tag List

 1Likes
  • 1 Post By unslow1
 
LinkBack Thread Tools
post #1 of 6 Old 04-01-2019, 6:57 PM Thread Starter
 
Join Date: 04-01-2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 0
 
954 dash problems

Just bought the bike and the dash only comes on when im pressing the front brake, thinking a short somewhere, any ideas?
BigBlue is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-01-2019, 7:07 PM
Heeza Y Zasch
 
unslow1's Avatar
 
Join Date: 09-14-2008
Location: Tioga County, NY
Posts: 3,013
Mentioned: 26 Post(s)
Tagged: 3 Thread(s)
Quoted: 383 Post(s)
Reputation Power: 58
                     
Re: 954 dash problems

1. check the gaugepod connector

2. check the blue & grey connectors under the right side duct cover
nigelrb likes this.

non-Honda fleet: EX250JAF, VL1500LC, ZX600-E1, ZX600-E12
"Some people wonder all their lives if they've made a difference. The Marines don't have that problem." -Ronald Reagan
unslow1 is offline  
post #3 of 6 Old 04-01-2019, 7:54 PM Thread Starter
 
Join Date: 04-01-2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 0
 
Will check tomorrow after work, thanks
BigBlue is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 05-14-2019, 5:47 PM Thread Starter
 
Join Date: 04-01-2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 0
 
So finally got around to taking a better look into this and it seems like the front brake switch has something to do with it. When I bypass the switch everything works fine, took the switch apart and it appears to be working correctly. Previous owner changed out the taillight and I notice two connectors under the passenger seat, orange and blue both have the green wires clipped. Could this have anything to do with it?
BigBlue is offline  
post #5 of 6 Old 05-14-2019, 6:55 PM
President: Team Full Chat
 
IanDoohan's Avatar
 
Join Date: 06-28-2013
Location: Connecticut,USA
Age: 47
Posts: 6,951
Mentioned: 64 Post(s)
Tagged: 4 Thread(s)
Quoted: 625 Post(s)
Reputation Power: 101
                     
Garage
Re: 954 dash problems

Quote:
Originally Posted by BigBlue View Post
So finally got around to taking a better look into this and it seems like the front brake switch has something to do with it. When I bypass the switch everything works fine, took the switch apart and it appears to be working correctly. Previous owner changed out the taillight and I notice two connectors under the passenger seat, orange and blue both have the green wires clipped. Could this have anything to do with it?
It sure could, but the orange and blue are the blinker wires. But not having them grounded could surely be a problem.

My 99 900RR Track Build Link:Track Build 900RRX

My Red Rocker 93 Build Link: Café 900RRP
IanDoohan is offline  
post #6 of 6 Old 05-14-2019, 7:25 PM Thread Starter
 
Join Date: 04-01-2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 0
 
Side note I checked the pin connector going into the cluster and also the blue and gray connectors behind the air duct and they seem fine. Only thing I can think is there is a ground from when the integrated tail light was installed. From the looks of things they seem to have done it right, soldered all the connections and shrink wrapped. I will try to reconnect the ground from the turn signals but I have a feeling the issue is something else.
BigBlue is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > General Motorcycling > Electronics

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cbr929 head on 954 bottom end Cbrmedina Honda FireBlade 0 09-17-2018 11:30 AM
AU bike with US dash HISS programming issue Tcoo7399 Electronics 5 08-24-2018 3:53 AM
02 954 Low Speed Driveability Issues JMooreHarrier2 Honda FireBlade 27 06-26-2018 11:06 PM
2002 954 w/Ohlins For Sale! $4700 OBO in Wisconsin davef Motorcycles For Sale 2 05-18-2018 9:15 AM
2003 954 power issues Kylep7888 General Discussion 4 05-12-2018 4:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome