CBR 929 starting issues - Honda Motorcycles - FireBlades.org
General Discussion General Motorcycle Discussion. If it's related to motorcycles in any way, and doesn't fit into a more specific forum, it goes here.

User Tag List

 
LinkBack Thread Tools
post #1 of 5 Old 08-27-2019, 12:33 PM Thread Starter
 
Join Date: 08-26-2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
CBR 929 starting issues

Hi all I have a CBR 929 and I'm having starting issues sometimes it will start first turn of the key others it can take 15 or more turns it's been put on a diagnostic machine when started and it finds nothing I've had a new key done to rule that out a new fuel pump relay when the fuel pump primes every time when tested all wires coming from the ECU have been tested and are fine,what happens is the fuel pump doesn't always prime and when it does I don't always get a spark ignition has been tested and a spare tried but no change,when it starts it runs fine it's just not knowing if it's going to restart or how long it will take to restart at the end of a ride I'm at a loss of ideas now the only thing left is the tilt sensor that I'm going to try any other ideas please
Pebs is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-28-2019, 1:36 PM
Supporting Member
 
oldbastard's Avatar
 
Join Date: 05-10-2010
Location: Holland
Posts: 267
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Reputation Power: 15
           
Re: CBR 929 starting issues

if you dont hear the fuel pump running for a couple of seconds when you first switch on, dont even bother spinning the engine. I would guess that you have a fuel pump issue, more than likely a relay or bad connector. Does it ever NOT start when the fuel pump has done its initial pump-up?
oldbastard is offline  
post #3 of 5 Old 09-02-2019, 6:54 AM
 
Join Date: 06-11-2019
Location: UK
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
How many miles on it? Is it still on original spark plugs? Does the fuel pump prime every time? Air filter clean?
chris4652009 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 09-04-2019, 8:04 AM
 
Join Date: 03-21-2005
Location: Wiltshire, uk
Age: 52
Posts: 1,164
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Reputation Power: 20
         
Re: CBR 929 starting issues

I would suspect a bad earth in the loom causing this - I'll post up some info later - at work atm!


you could look at this which happened to mine too:
https://www.fireblades.org/forums/ho...post1699314873
machinehead is offline  
post #5 of 5 Old 09-15-2019, 1:38 PM Thread Starter
 
Join Date: 08-26-2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
It's just had a new fuel pump put in and a fresh service new plugs oil etc it on 42k it was doing it before the service mechanic thought he sorted after finding a split wire going to the fuel pump it lasted the ride home all of 10mins as soon as I stopped and turned it off it wouldn't restart you can hear the relay click bad it will turn over its not until it's totally cooled down then it takes a few turns of the key before it primes the mechanic even tried the tilt sensor when the pumps out the tank he said it primes every time it seems to only have the issue after riding
Pebs is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > General Motorcycling > General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome