2002 954 fuel pump issue - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 15 Old 07-11-2013, 8:24 PM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
2002 954 fuel pump issue

can anyone help me out.

this is the story

bought a 954 it ran for a couple days and all the sudden fuel pump died. so i changed the pump and got it from an aftermarket company. the pump started at first when i jumped it off the battery and then installed it. ran for a lil (15 min on a test ride) and then when i turned the bike off it wouldnt start up. took pump off... no power.

could it still be the ignition if it started it off the new pump?

when i say i, i mean the mechanic at a shop in phx. they are newer. but they say they checked all fuses and relays ect. there is gas in it. i have been reading about this a lot but i have not found an answer to the above question. sorry if this is a repost. please help! i have a lot of parts on the way from an online shopping spree!
thanks
k1llapanda is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 07-11-2013, 9:00 PM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

all these views no replies! come on guys :,(
k1llapanda is offline  
post #3 of 15 Old 07-11-2013, 11:36 PM
 
Join Date: 06-24-2013
Location: idaho
Posts: 244
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 8
   
Re: 2002 954 fuel pump issue

Quote:
Originally Posted by k1llapanda View Post
all these views no replies! come on guys :,(

check your grounds
chris954rr is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old 07-11-2013, 11:37 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 2002 954 fuel pump issue

Quote:
Originally Posted by k1llapanda View Post
can anyone help me out.

this is the story

bought a 954 it ran for a couple days and all the sudden fuel pump died. so i changed the pump and got it from an aftermarket company. the pump started at first when i jumped it off the battery and then installed it. ran for a lil (15 min on a test ride) and then when i turned the bike off it wouldnt start up. took pump off... no power.

could it still be the ignition if it started it off the new pump?

when i say i, i mean the mechanic at a shop in phx. they are newer. but they say they checked all fuses and relays ect. there is gas in it. i have been reading about this a lot but i have not found an answer to the above question. sorry if this is a repost. please help! i have a lot of parts on the way from an online shopping spree!
thanks

Is it a high-pressure pump?
You need to make at least 50psi, which most aftermarket pumps won't do.
Car injection systems generally run lower than this.

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #5 of 15 Old 07-11-2013, 11:42 PM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

the fuel pump will not get any volts when it is off the bike jumped. dunno if that helps the analysis. grounds are good.dont have a way to check psi....
k1llapanda is offline  
post #6 of 15 Old 07-11-2013, 11:43 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 2002 954 fuel pump issue

Quote:
Originally Posted by k1llapanda View Post
the fuel pump will not get any volts when it is off the bike jumped. dunno if that helps the analysis. grounds are good.dont have a way to check psi....

The specification sheet for the pump will say what pressure it's rated for.

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #7 of 15 Old 07-11-2013, 11:46 PM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

would it not get power if the psi was off by a lil?
k1llapanda is offline  
post #8 of 15 Old 07-11-2013, 11:48 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 2002 954 fuel pump issue

Quote:
Originally Posted by k1llapanda View Post
would it not get power if the psi was off by a lil?

Not if you tested it before putting it on the bike.
Since the bike is designed to power a high-pressure pump perhaps it damaged it when you ran it?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #9 of 15 Old 07-12-2013, 1:02 AM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

ok.
so i tested it. it turned on
installed it, bike ran for a lil
turned it off
now its dead

so basically i coulda shorted it out?
k1llapanda is offline  
post #10 of 15 Old 07-12-2013, 2:04 AM
 
Join Date: 07-15-2010
Location: My comfy chair
Posts: 4,122
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 66
                     
Garage
Re: 2002 954 fuel pump issue

Check to see if you have power to the pump in the first place (now) and recheck your fuses if you do not. If you do have power to the pump then the problem lies (most likely) in the ground or pump.. easiest to check the pump ground with a voltmeter/continuity checker. Try that out first.

/**Serenity**\ 2002 Honda CBR954RR Fireblade

"But risks must be taken, because the greatest risk in life is to risk nothing. Only the person who risks is truly free."
RRDemon is offline  
post #11 of 15 Old 07-13-2013, 12:50 PM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

thanks everyone. i just got the new pump. an oem one this time haha. i will update you guys later this afternoon.
k1llapanda is offline  
post #12 of 15 Old 07-13-2013, 1:34 PM
 
Join Date: 07-12-2013
Location: New york city
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

My fuel pump won't prime at all, I checked it and it works fine directly from the battery, the bike cranks it just won't spark, when I grab the front of the wire harness the red mil light flickers there is a tiny piece of the blue harness burnt up, the one twards the front please help
Is it the ecu?
Should I buy a new wire harness
Ps the ignition is apart I am spinning the white disc to turn on ignition
wheelieJ is offline  
post #13 of 15 Old 07-13-2013, 2:12 PM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

Ok so got the new pump. Fuses relay and grou d are a go. The pump still sont prime. Hs continuity to where the ground goes in the pump and nothing
k1llapanda is offline  
post #14 of 15 Old 07-13-2013, 5:23 PM Thread Starter
 
Join Date: 07-05-2013
Location: Phoenix
Age: 33
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

ok so the pump gets power now. relay is good. but when i plug the pump into the bike it gets no power. when put on a battery it will prime. the kill switch/ starter has been replaced. all fuses and grounds are good as far as i know. mechanic said he tested all of them. this is been going on for over a week now. third pump was hoping to be a charm but its just more of a headache. please help me guys! text or call or anything 9492809195
i have a lot of money in **** that i bought for the bike to upgrade it. from levers to exhaust and mirrors to gear. so u can imagine my frustration. so to those that have helped thank u and if u can help me further that would rock. i am deep in labor to where the bike is not worth what i paid anymore so if anyone is in arizona and can help me out that would be even better.
jon
k1llapanda is offline  
post #15 of 15 Old 07-13-2013, 5:44 PM
 
Join Date: 07-12-2013
Location: New york city
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2002 954 fuel pump issue

Quote:
Originally Posted by k1llapanda View Post
ok so the pump gets power now. relay is good. but when i plug the pump into the bike it gets no power. when put on a battery it will prime. the kill switch/ starter has been replaced. all fuses and grounds are good as far as i know. mechanic said he tested all of them. this is been going on for over a week now. third pump was hoping to be a charm but its just more of a headache. please help me guys! text or call or anything 9492809195
i have a lot of money in **** that i bought for the bike to upgrade it. from levers to exhaust and mirrors to gear. so u can imagine my frustration. so to those that have helped thank u and if u can help me further that would rock. i am deep in labor to where the bike is not worth what i paid anymore so if anyone is in arizona and can help me out that would be even better.
jon
Please help Jon and I we seem to be having the same problem
wheelieJ is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump issue Amanzimtoti Honda FireBlade 2 10-19-2012 1:41 PM
Fuel pump issue... Nissler Honda FireBlade 2 04-25-2012 6:12 AM
Fuel pump issue. Chris Medellin Honda Cruisers 2 02-26-2011 9:42 PM
Fuel Pump issue, Plz help Chris Medellin General Discussion 4 02-20-2011 1:21 PM
Fuel pump issue? klayman Honda FireBlade 5 09-27-2006 8:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome