954 Turn signal issue - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 4 Old 07-30-2013, 8:58 PM Thread Starter
 
Join Date: 07-17-2009
Location: Frederick
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
954 Turn signal issue

I bought my bike a few weeks ago and it had some crappy flush mounts that were not LED lights. It kept blowing a fuse and the turn signals and brake light would not operate. I bought some Protons and put them on the front, and now the fuse isn't blowing after 5 minutes like before, but I can't get the back LED's in the undertail kit to work. When the turn signal is on, they are pretty much solid. I can see a tiny bit of strobing, but you wouldn't notice it at all if you were behind me.

I have the Protons set on strobe. I bought a relay for it, but I don't think that I'm putting it in the right spot (i'm new to the electrical stuff). I found a clip that fit the relay perfectly (right by the battery), but I don't think that is the right place.

Also, the strobe effect seems erratic and I'm guessing that has something to do with the wrong relay placement.

How can I fix the rear turn signals and where should I put the relay?
jcerion929rr is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-31-2013, 12:18 AM Thread Starter
 
Join Date: 07-17-2009
Location: Frederick
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Turn signal issue

I just read through this post

https://www.fireblades.org/forums/hon...r-relay-5.html

It answered all my questions. Sorry for jumping the gun before fully researching
jcerion929rr is offline  
post #3 of 4 Old 07-31-2013, 7:07 AM
 
Join Date: 04-03-2012
Location: Chasing range rovers.
Posts: 3,890
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 113
                     
Re: 954 Turn signal issue

You found the answer to your question - nothing wrong with that. More than a lot of people do on forums

If the bike isn't braking properly, you don't start by rebuilding the engine.
Sky91 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 07-31-2013, 2:42 PM
 
Join Date: 10-17-2007
Location: hotlanta, south cack-a-lacky, the 'Burgh
Posts: 193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Reputation Power: 13
 
Send a message via Yahoo to kahlilj
Re: 954 Turn signal issue

Quote:
Originally Posted by jcerion929rr View Post
I just read through this post

https://www.fireblades.org/forums/hon...r-relay-5.html

It answered all my questions. Sorry for jumping the gun before fully researching

lol! I was just about to refer you to this same thread. Jawz helped me to sort my problem as well. I shared my experience in that same thread. Hope you got it all figured out
kahlilj is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Tags
954 , 954rr , cbr , cbr954 , cbr954rr

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Issue Cujo98 General Discussion 9 08-30-2012 5:55 PM
Turn signal issue k_schutte Honda FireBlade 29 03-28-2012 9:22 PM
turn signal help adidrick Electronics 8 08-08-2011 12:18 PM
Turn Signal Help avlastakis Electronics 4 08-19-2008 4:39 PM
Turn Signal Help youngandpayd Electronics 2 05-26-2008 9:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome