coincidence or not - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 5 Old 10-11-2013, 8:03 PM Thread Starter
 
Join Date: 08-04-2013
Location: Mountville sc
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 7
 
coincidence or not

hey all I just installed some shorty levers on my 900rr 97 model love them so far but since installing my clutch slips I didn't mess with any adjustment at all just put them in could they be causing my clutch to slip in any way possible
Mikew90 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 10-12-2013, 2:18 AM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 230
                     
Re: coincidence or not

Quote:
Originally Posted by Mikew90 View Post
hey all I just installed some shorty levers on my 900rr 97 model love them so far but since installing my clutch slips I didn't mess with any adjustment at all just put them in could they be causing my clutch to slip in any way possible

Try adjusting the cable.
Simple way to know is to put the OEM lever back on.

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #3 of 5 Old 10-12-2013, 10:28 AM Thread Starter
 
Join Date: 08-04-2013
Location: Mountville sc
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 7
 
Re: coincidence or not

I figured out why its slipping but don't know how to remedy it the lever is not returning fully leaving a quarter inch or so between the lever and clip on if I push it to rest it doesn't slip but I don't know why it won't rest fully the oem never did this
Mikew90 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 10-12-2013, 10:31 AM
 
Join Date: 04-03-2012
Location: Chasing range rovers.
Posts: 3,890
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 113
                     
Re: coincidence or not

Did you clean the housing and use some white lithium grease to lube the new lever? Have you tried adjusting the cable yet?

If the bike isn't braking properly, you don't start by rebuilding the engine.
Sky91 is offline  
post #5 of 5 Old 10-12-2013, 12:00 PM
 
Join Date: 06-01-2011
Location: Quartz Hill, Ca
Posts: 3,226
Mentioned: 2 Post(s)
Tagged: 2 Thread(s)
Quoted: 159 Post(s)
Reputation Power: 122
                     
Garage
Re: coincidence or not

Quote:
Originally Posted by Mikew90 View Post
I figured out why its slipping but don't know how to remedy it the lever is not returning fully leaving a quarter inch or so between the lever and clip on if I push it to rest it doesn't slip but I don't know why it won't rest fully the oem never did this
Disconnect the cable and see if the lever moves freely in the housing, if it does proceed like BR and Sky said. Definitely make sure the housing is clean and put a little grease on it. If it doesn't, find out why. might have to do a little work with a fine file.

"You live more for 5 minutes going fast on a bike than other people do in all their life"-Marco Simoncelli
fj1200rj is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Coincidence? OSIRIS Off-Topic 0 09-28-2006 12:16 PM
Strange coincidence DUX Off-Topic 0 12-10-2005 6:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome