99 blade, possible rectifier problem. - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 2 Old 03-13-2014, 3:04 PM Thread Starter
 
Join Date: 04-02-2013
Location: Plymouth
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
99 blade, possible rectifier problem.

Hi all,

Well, I broke down today, no power whatsoever. I found out the main fuse was blown and when i put a new one in that blew straight away as well. When I got it recovered to my house, i took the cover off and tried again, this time the rectifier started blowing out smoke! So I did what I should have done in the first place and looked on here. Please correct me if I'm wrong but it seems that honda sports bikes and rectifiers are a problem and I've seen some suggestions to change the rectifier for one from another bike. so:

1. Is it likely that the rectifier is the fault rather than a symptom of the actual fault? I dont want to be buying rectifiers every couple off weeks, I'd rather spend time finding the cause of the problem.

2. Can anyone recommend a rectifier from another bike (UK if it makes any difference) that will last longer.

Thanks very much.
martinH is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-20-2014, 10:41 AM Thread Starter
 
Join Date: 04-02-2013
Location: Plymouth
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 99 blade, possible rectifier problem.

Well I put in a new rectifier, a new one for a 2003 gsxr. I soldered the connections together and ran the bike and checked it all out and everything was great. Then I took it out for the day and when I got back I thought I'd just check again and now the voltage is way too high. Its getting about 17.5 to 18.5v at 5000rpm. The battery is getting a bit warm due to the increased voltage. The battery is pretty new, when I got it I stuck it on charge with an oxford optimizer 900 overnight. I've been through all the wiring and all seems ok except for one indicator bulb is badly corroded and will be replaced soon.

I found a flowchart to go through on the internet and I followed that all the way through and everything is as it should be. Does anyone have any other suggestions please?
martinH is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
R1 Regulator/Rectifier swap to solve the problem FlatBlackBlade Honda FireBlade 15 10-27-2013 5:39 AM
Rectifier regulator problem trying to fix ragecage8966 Electronics 3 08-17-2013 6:22 AM
Cbr400 rectifier problem !?!? Blade_BKA Honda CBR400RR 3 10-21-2009 4:47 PM
Electrical Problem, Rectifier? aifilaw Honda FireBlade 19 07-26-2009 9:07 PM
battery or regulator/rectifier problem wsuhockeyguy Honda CBR 600 3 06-26-2009 2:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome