954 Won't start - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 13 Old 03-24-2014, 1:16 PM Thread Starter
 
Join Date: 03-21-2014
Location: Leicester
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
954 Won't start

Hi everyone, I'm James. Sorry this is my first post but I need some help with my 954.

I've got a 954 FireBlade that I took the tank off to get sprayed, whilst it was away I fitted a PCIII and the quick release fuel couplings.

I got the tank back rigged it all up and initially the pump wouldn't prime when I turned the ignition on. The next time I tried it the pump primed but it doesn't start. I've ruled out the fuel cut off relay as I swapped it for the headlight relay, I've disconnected the PCIII.

Still no joy, then I put new fuel hoses on without the quick release couplings, the fuel pump connector is getting 11.8 volts so that's not the problem. It's sparking as I sprayed carb cleaner in the throttle bodies and it fires straight up so it's definitely fuel related.

I then ran the pump constantly off another battery and tried to fire the bike up but still nothing. It's not showing any FI codes on the dash, anyone got any other ideas?

I suspect it is the pump but don't have another to test it against. If it is the pump how on earth did it just give up the ghost?

Another odd thing is I don't think the fuel level sensor is working as there is only a few litres of fuel in there and it isn't on, it also doesn't light up when you turn the ignition on.
NCSprinter30 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 03-24-2014, 1:52 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 954 Won't start

Quote:
Originally Posted by NCSprinter30 View Post
Hi everyone, I'm James. Sorry this is my first post but I need some help with my 954.

I've got a 954 FireBlade that I took the tank off to get sprayed, whilst it was away I fitted a PCIII and the quick release fuel couplings.

I got the tank back rigged it all up and initially the pump wouldn't prime when I turned the ignition on. The next time I tried it the pump primed but it doesn't start. I've ruled out the fuel cut off relay as I swapped it for the headlight relay, I've disconnected the PCIII.

Still no joy, then I put new fuel hoses on without the quick release couplings, the fuel pump connector is getting 11.8 volts so that's not the problem. It's sparking as I sprayed carb cleaner in the throttle bodies and it fires straight up so it's definitely fuel related.

I then ran the pump constantly off another battery and tried to fire the bike up but still nothing. It's not showing any FI codes on the dash, anyone got any other ideas?

I suspect it is the pump but don't have another to test it against. If it is the pump how on earth did it just give up the ghost?

Another odd thing is I don't think the fuel level sensor is working as there is only a few litres of fuel in there and it isn't on, it also doesn't light up when you turn the ignition on.

Is the bank angle sensor correctly mounted?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #3 of 13 Old 03-24-2014, 1:57 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 954 Won't start

I'd be suspicious of your fuel pump regulator. But I'd also test the fuel pump for the correct fuel flow. And test pressure too, if you can get a gauge to test that. Or just replace the fpr and hope that fixes it.

Just to clarify, you are getting the proper prime when you turn on the ignition switch? Because you bank angle relay is tied into your fuel pump relay. Check that BA relay and check the BA mounting is proper too.
Also check your sidestand switch, that can cause a no start.

And lastly, do you have a good strong battery? It needs to read at least 12.5 VDC or more at rest. Use a jumper battery if any doubt.
jondog9 is offline  
Sponsored Links
Advertisement
 
post #4 of 13 Old 03-24-2014, 4:35 PM
 
Join Date: 07-15-2010
Location: My comfy chair
Posts: 4,123
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 66
                     
Garage
Re: 954 Won't start

Can't believe this has been overlooked... Disconnect your PCIII and reconnect the two stock harnesses to rule out a faulty PCIII. After that, I would start double checking any electrical connections to make sure they are all in and tight. If it was running just dandy before the changes, it usually means you mucked something up accidentally while re-installing everything. I know it sucks to think you are the problem, but I know from experience (many times over) that things can get overlooked when you are happily re-assembling...

/**Serenity**\ 2002 Honda CBR954RR Fireblade

"But risks must be taken, because the greatest risk in life is to risk nothing. Only the person who risks is truly free."
RRDemon is offline  
post #5 of 13 Old 03-24-2014, 6:40 PM Thread Starter
 
Join Date: 03-21-2014
Location: Leicester
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Won't start

I haven't touched the bank sensor, does that kill the spark or the fuel injection because it sparks fine and dandy. I have unplugged the pc3, yeah it was running fine which is why it's so annoying. I hardly unplugged anything. Some one else removed the fuel pump from the tank but he says it wasn't damaged in any way. Could the fuel pump be faulty but still pump but not generate enough pressure? It doesn't attempt to start or fire at all like complete fuel starvation.

I'll check the fuel pressure regulator tomorrow, can you repair them with a new diaphram or is a new one from Honda the only option? Could the fpr stop it from running completely?
NCSprinter30 is offline  
post #6 of 13 Old 03-24-2014, 8:56 PM
 
Join Date: 03-18-2014
Location: USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
                     
blunt is offline  
post #7 of 13 Old 03-25-2014, 12:28 AM Thread Starter
 
Join Date: 03-21-2014
Location: Leicester
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Won't start

Which hose is the return to the fuel pump? Does the pump pressurise the right hand side of the fuel rail or the left? If it's the right then I know what's the problem....
NCSprinter30 is offline  
post #8 of 13 Old 03-25-2014, 2:32 AM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 954 Won't start

Quote:
Originally Posted by NCSprinter30 View Post
I haven't touched the bank sensor, does that kill the spark or the fuel injection because it sparks fine and dandy. I have unplugged the pc3, yeah it was running fine which is why it's so annoying. I hardly unplugged anything. Some one else removed the fuel pump from the tank but he says it wasn't damaged in any way. Could the fuel pump be faulty but still pump but not generate enough pressure? It doesn't attempt to start or fire at all like complete fuel starvation.

I'll check the fuel pressure regulator tomorrow, can you repair them with a new diaphram or is a new one from Honda the only option? Could the fpr stop it from running completely?

Have you tried starter fluid?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #9 of 13 Old 03-25-2014, 3:54 AM Thread Starter
 
Join Date: 03-21-2014
Location: Leicester
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Won't start

Yeah I sprayed carb cleaner into the airbox and it fired straight up. Which hose goes to which end of the fuel rail as I may have the mixed up?
NCSprinter30 is offline  
post #10 of 13 Old 03-25-2014, 4:01 AM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 954 Won't start

Quote:
Originally Posted by NCSprinter30 View Post
Yeah I sprayed carb cleaner into the airbox and it fired straight up. Which hose goes to which end of the fuel rail as I may have the mixed up?

It's not possible to mix them up, only the right end of the fuel rail is threaded to take the banjo from the tank. The low-pressure return hose comes off the regulator at the left end of the rail.
THROTTLE BODY ASSY 02-03

FUEL PUMP 2

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #11 of 13 Old 03-25-2014, 12:18 PM Thread Starter
 
Join Date: 03-21-2014
Location: Leicester
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Won't start

Maybe just maybe I err I mean my mate chopped the lines to fit quick release couplings and when putting it back together put the fuel lines the wrong way round. Haha what a knob I am err I mean my mate is! Started first stab of the button once corrected!
NCSprinter30 is offline  
post #12 of 13 Old 03-25-2014, 3:57 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 954 Won't start

Give yur mate a swift kick in the pants! Lol!
jondog9 is offline  
post #13 of 13 Old 03-25-2014, 11:51 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 954 Won't start

Quote:
Originally Posted by NCSprinter30 View Post
Maybe just maybe I err I mean my mate chopped the lines to fit quick release couplings and when putting it back together put the fuel lines the wrong way round. Haha what a knob I am err I mean my mate is! Started first stab of the button once corrected!

I hope the fittings and the crimps to the hoses are rated to hold more than 50psi.
How often do you expect to be removing the fuel tank?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
09 Cbr1000 tried to start by itself. Now won't start. anti_everything General Discussion 9 05-20-2012 10:33 AM
cant start, wont start shanelufc Honda CBR400RR 3 01-28-2011 2:44 AM
1999 Fireblade hard start, now wont start.... MFB_87 Honda FireBlade 15 03-18-2010 11:58 PM
'00 F4 - Won't Start, where do i start? cranks but doesnt fire. dunkd Honda CBR 600 7 07-30-2007 5:32 PM
cold start(how does your 954 start) JakeT Honda FireBlade 21 06-28-2005 11:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome