02 954RR Wont Run Unless Ignition Switch is Pressed! - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 5 Old 08-29-2014, 3:35 AM Thread Starter
 
Join Date: 08-29-2014
Location: Eugene, OR
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
02 954RR Wont Run Unless Ignition Switch is Pressed!

Hey everyone, just joined.

I ride a 2002 CBR954RR with about 31k miles. Has been running like a top since January, but today it randomly gave me trouble.

After riding in the morning, and sitting for a few hours, the bike would not start. Starter sounded strong, plenty of gas, and battery seemed good through multiple attempts, but the starter motor would just spin with no catch.
After a few tries, the bike would start right up like normal, but will only idle and run if the ignition switch is firmly pressed down. The engine will immediately shut off if I release the starter switch.

So now if I try to start it it will either 1) starter motor will click and spin but engine will not fire up. or 2) engine will fire right up but only as long as my thumb is pressing the ignition switch.

Managed to awkwardly ride it a mile to my house with my thumb pinning the ignition switch. Couldn't have been good for the starter but I had no choice, and it still sounds fine.

Some friends say it could be a bad starter switch, or a bad relay somewhere. I am not experienced with these kind of issues!

Please help!!!! Riding season is nearing an end here in Oregon.
russellhornsby is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-29-2014, 5:50 AM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 230
                     
Re: 02 954RR Wont Run Unless Ignition Switch is Pressed!

Quote:
Originally Posted by russellhornsby View Post
Hey everyone, just joined.

I ride a 2002 CBR954RR with about 31k miles. Has been running like a top since January, but today it randomly gave me trouble.

After riding in the morning, and sitting for a few hours, the bike would not start. Starter sounded strong, plenty of gas, and battery seemed good through multiple attempts, but the starter motor would just spin with no catch.
After a few tries, the bike would start right up like normal, but will only idle and run if the ignition switch is firmly pressed down. The engine will immediately shut off if I release the starter switch.

So now if I try to start it it will either 1) starter motor will click and spin but engine will not fire up. or 2) engine will fire right up but only as long as my thumb is pressing the ignition switch.

Managed to awkwardly ride it a mile to my house with my thumb pinning the ignition switch. Couldn't have been good for the starter but I had no choice, and it still sounds fine.

Some friends say it could be a bad starter switch, or a bad relay somewhere. I am not experienced with these kind of issues!

Please help!!!! Riding season is nearing an end here in Oregon.

The ignition switch is where you put the key in, I'm guessing you are referring to the starter button.
While you are holding the starter button in, the engine revs normally?
I would have to guess there's a problem in the right switch cluster.
Nothing has been done to the bike since you last rode it?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #3 of 5 Old 08-29-2014, 12:01 PM Thread Starter
 
Join Date: 08-29-2014
Location: Eugene, OR
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 02 954RR Wont Run Unless Ignition Switch is Pressed!

Yes starter switch, my bad with the terminology. Nothing at all has been done to the bike since I rode it last, never had electrical problems. Bike seems to rev normally when running (all while starter switch is pressed, because it won't run without it).
Only difference is I recently moved and the bikewas kept outside for a night or two, but all in nice, warm weather although it can get a little hot during the day (85-90 deg).
russellhornsby is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 08-29-2014, 5:01 PM
 
Join Date: 08-03-2014
Location: holland
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 02 954RR Wont Run Unless Ignition Switch is Pressed!

I dont have a 954 but on my 900 the start button is in the same housing as the engine kill switch. Maybe it got some water/moist in it when you left it outside and there is some sort of short or bad connection in the killswitch?
dutchhonda is offline  
post #5 of 5 Old 08-30-2014, 5:52 AM
President: Team Full Chat
 
IanDoohan's Avatar
 
Join Date: 06-28-2013
Location: Connecticut,USA
Age: 47
Posts: 7,219
Mentioned: 71 Post(s)
Tagged: 4 Thread(s)
Quoted: 749 Post(s)
Reputation Power: 102
                     
Garage
Re: 02 954RR Wont Run Unless Ignition Switch is Pressed!

Quote:
Originally Posted by bladeracer View Post
The ignition switch is where you put the key in, I'm guessing you are referring to the starter button.
While you are holding the starter button in, the engine revs normally?
I would have to guess there's a problem in the right switch cluster.
Nothing has been done to the bike since you last rode it?
Quote:
Originally Posted by dutchhonda View Post
I dont have a 954 but on my 900 the start button is in the same housing as the engine kill switch. Maybe it got some water/moist in it when you left it outside and there is some sort of short or bad connection in the killswitch?

I agree with both of these gentlemen. I would suspect some corrosion or maybe a broken wire in the right switch cluster. Take it apart and check.

My 99 900RR Track Build Link:Track Build 900RRX

My Red Rocker 93 Build Link: Café 900RRP
IanDoohan is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Tags
cbr954rr , fireblade , ignition , problem , starter

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connector type (and where to buy it?) for kill switch / start switch on a 954RR 2003 ovidiugm Honda FireBlade 4 06-29-2014 4:49 AM
954 ignition switch on 900 rr? delian Honda FireBlade 0 07-20-2012 12:48 AM
where can i get the whole ignition switch for a 954RR kagmyster00 Honda FireBlade 4 09-17-2008 8:09 PM
where can i get the whole ignition switch for a 954RR kagmyster00 Electronics 0 09-15-2008 6:14 PM
need help ignition switch widebody Honda FireBlade 7 12-12-2004 11:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome