CBR 954 not running right - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 6 Old 09-24-2014, 12:31 AM Thread Starter
 
Join Date: 11-15-2010
Location: central California
Age: 50
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 10
   
Send a message via Yahoo to letsride
CBR 954 not running right

I had cbr 954 out at the track this past weekend and bike ran awesome for first hr.After that bike started getting a stumble around 7k rpm and only when getting on the power hard.Any suggestions on what it could be?
letsride is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-24-2014, 2:51 AM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: CBR 954 not running right

Quote:
Originally Posted by letsride View Post
I had cbr 954 out at the track this past weekend and bike ran awesome for first hr.After that bike started getting a stumble around 7k rpm and only when getting on the power hard.Any suggestions on what it could be?

Fuel pressure regulator?
Charging system?
Servo motor?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #3 of 6 Old 09-24-2014, 4:05 PM Thread Starter
 
Join Date: 11-15-2010
Location: central California
Age: 50
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 10
   
Send a message via Yahoo to letsride
Re: CBR 954 not running right

Charging system is fine,don't have a servo motor,will have to check FPR over the weekend,any other suggestions on what to check?
letsride is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 09-24-2014, 6:51 PM
 
Join Date: 05-16-2012
Location: Finland
Posts: 717
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 33 Post(s)
Reputation Power: 16
             
Re: CBR 954 not running right

Quote:
Originally Posted by letsride View Post
Charging system is fine,don't have a servo motor,will have to check FPR over the weekend,any other suggestions on what to check?
Plugs, coils, injectors, wiring and check that the air filter isn't clogged. Probably it doesn't get fuel or something wrong with the spark. Have you checked the fault codes. Do you have the MIL light on because of the removed servo?
mika_u is offline  
post #5 of 6 Old 09-24-2014, 7:55 PM Thread Starter
 
Join Date: 11-15-2010
Location: central California
Age: 50
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 10
   
Send a message via Yahoo to letsride
Re: CBR 954 not running right

Has new air filter,servo motor has plug so no fault codes come up.Will be draining fuel in tank in case it was bad fuel,will also check plugs and coils this weekend and see what comes up.Bike was running perfect just before it started doing it.
letsride is offline  
post #6 of 6 Old 10-25-2014, 10:39 AM Thread Starter
 
Join Date: 11-15-2010
Location: central California
Age: 50
Posts: 146
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 10
   
Send a message via Yahoo to letsride
Re: CBR 954 not running right

Found the problem.Had a loose wire on the power commander.
letsride is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Not running again! mike2012 Honda CBR400RR 9 10-03-2012 2:30 PM
running on 2 400 Honda CBR400RR 4 09-18-2012 7:05 AM
954 getting 20 mpg, running well though - FPR?? 929cc Honda FireBlade 2 11-09-2010 12:32 PM
Running HOT Marc954rr Honda FireBlade 8 08-03-2009 12:15 AM
running lights....not running antisleepman Honda RC51 3 03-17-2008 8:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome