2003 CBR954 Fuel pump wont prime - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 13 Old 10-15-2014, 8:25 AM Thread Starter
 
Join Date: 10-15-2014
Location: Australia
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
2003 CBR954 Fuel pump wont prime

Hi Guys. I am a newey here

I have a CBR954.

I turn the ignition on and the fuel pump will not prime. I have checked the fuel pump and have been able to jump it with a battery and with works well.

I have checked the side stand switch and tip over sensor.

Still no luck.

Do you have any suggestions?

Help is appreciated!!
screamingeagle is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 10-15-2014, 2:37 PM
 
Join Date: 05-09-2013
Location: new jersey
Posts: 260
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 7
 
Re: 2003 CBR954 Fuel pump wont prime

Make sure your kill switch is in good order or see if it cranks that way you know it's not the kill switch. It could be the stupidest thing. Maybe a plug you're missing
dazodiac is offline  
post #3 of 13 Old 10-15-2014, 2:43 PM
 
Join Date: 05-27-2014
Location: Magnet Indiana
Age: 39
Posts: 3,520
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Reputation Power: 47
                     
Re: 2003 CBR954 Fuel pump wont prime

did you check the relay? try switching the headlight relay with the fuel pump relay. if it primes you have your problem....

"love is the feeling you get when you like something as much as your motorcycle."-Hunter S. Thompson
954Kevin is offline  
Sponsored Links
Advertisement
 
post #4 of 13 Old 10-15-2014, 5:03 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 2003 CBR954 Fuel pump wont prime

Quote:
Originally Posted by 954Kevin View Post
did you check the relay? try switching the headlight relay with the fuel pump relay. if it primes you have your problem....


Common thing for the OEM relays to fail after about 10 years of service.
I had all three of my relays fail within a year.
Get them from Honda, the Chinese cheapies only last a short time, I discovered in my other vehicles. Never tried them in my bike, in fact, I carry an extra Honda relay in my tool kit.
jondog9 is offline  
post #5 of 13 Old 10-15-2014, 5:06 PM
 
Join Date: 05-09-2013
Location: new jersey
Posts: 260
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 7
 
Re: 2003 CBR954 Fuel pump wont prime

Part#? I'll buy one just to have it also
dazodiac is offline  
post #6 of 13 Old 10-15-2014, 5:21 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 2003 CBR954 Fuel pump wont prime

Quote:
Originally Posted by dazodiac View Post
Part#? I'll buy one just to have it also
Check with East Toledo Honda, they're one of the best priced OEM suppliers and I've had great luck with them for all sorts of parts.

Parts Finder Honda East Toledo Maumee, OH 1-877-437-1631
jondog9 is offline  
post #7 of 13 Old 10-15-2014, 5:33 PM Thread Starter
 
Join Date: 10-15-2014
Location: Australia
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2003 CBR954 Fuel pump wont prime

Thanks Guys.

It cranks fine. Just fuel pump is not starting.

I have powered up all 4 of my relays and they all tick perfectly.

Lets start from the beginning.

I bought the bike complete, smashed as a write off. to use the engine for my buggy project.

At the time of purchase the bike was not able to be started due to the front end damage, which destroyed the dash and some of the wiring, I did a deal with the seller to fix it and I will purchase the bike. He was a motor bike wrecker so it was no big deal, just charged me an extra $200.

When I received the bike there was no wires to the ignition. I rang him up and he said find the two wires hanging out, put them two together, so I did, and it started and purred like a pussy.

I stripped the bike down and sold off the left over parts like the forks, wheels and frame,

Now I look back and realised that I did not take off the ignition system. Because at the time I did not think I would need it as it was not connected up in the first place.

I purchased a Ignition cheap here in Australia for $40.

Now some buggy forum members have just explained to me about the Honda HISS system, the ignition, ECU and Transponder are a matching set!!

I was told to purchase a secondhand ECU and harness of ebay.com and get it from America as the Hondas over there do NOT have HISS. I purchased a ECU and Harness from there.

I have fitted it all. Still have had no luck.

I am wondering if the ignition might be stopping me? But Honestly have have done it with the wiring the guy made up to bypass the ignition to start it, All it is, Is a plug the same as the ignition plug and it has 2 wires out of it to join together.

Does this give you guys any clues?
screamingeagle is offline  
post #8 of 13 Old 10-19-2014, 7:14 AM Thread Starter
 
Join Date: 10-15-2014
Location: Australia
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 2003 CBR954 Fuel pump wont prime

Can anyone post me a pic of what the plug looks like that I have to bypass to get the error codes up?

Appreciate your reply.
screamingeagle is offline  
post #9 of 13 Old 10-19-2014, 9:52 AM
 
Join Date: 05-27-2014
Location: Magnet Indiana
Age: 39
Posts: 3,520
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Reputation Power: 47
                     
Re: 2003 CBR954 Fuel pump wont prime




"love is the feeling you get when you like something as much as your motorcycle."-Hunter S. Thompson
954Kevin is offline  
post #10 of 13 Old 10-20-2014, 11:40 AM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 2003 CBR954 Fuel pump wont prime

You're not bypassing it, you use a wire to bridge both pins in the connector.
I made one up by taking a short piece of 16 gauge wire and dropping a little solder in both ends, and then flatten them with a hammer and file till they fit real nice in the connector.
jondog9 is offline  
post #11 of 13 Old 10-20-2014, 12:51 PM
 
Join Date: 05-27-2014
Location: Magnet Indiana
Age: 39
Posts: 3,520
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Reputation Power: 47
                     
Re: 2003 CBR954 Fuel pump wont prime

ive even heard of people just putting a paper clip in each side of it to bridge it. granted jondog9's approach would be the preferred way to do it!

"love is the feeling you get when you like something as much as your motorcycle."-Hunter S. Thompson
954Kevin is offline  
post #12 of 13 Old 10-20-2014, 2:42 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 2003 CBR954 Fuel pump wont prime

Yep, a paperclip works just fine. anything really. I just made one up to have as a tool whenever needed.
jondog9 is offline  
post #13 of 13 Old 10-21-2014, 6:54 PM
Heeza Y Zasch
 
unslow1's Avatar
 
Join Date: 09-14-2008
Location: Tioga County, NY
Posts: 3,023
Mentioned: 26 Post(s)
Tagged: 3 Thread(s)
Quoted: 385 Post(s)
Reputation Power: 59
                     
Re: 2003 CBR954 Fuel pump wont prime

Quote:
Originally Posted by screamingeagle View Post
Thanks Guys.

It cranks fine. Just fuel pump is not starting.

I have powered up all 4 of my relays and they all tick perfectly.
they can (and do) still "ACT" like they work from time-to-time...
even read appropriate voltage/ohms when tested... but when power applied they won't work properly

my money's bet is on your HISS system though... from what I've read on here anyway.

...and here's the part # for all FOUR relays (including the one UNder the seat):
Attached Thumbnails
P8070025DT.jpg‎  

non-Honda fleet: EX250JAF, VL1500LC, ZX600-E1, ZX600-E12
"Some people wonder all their lives if they've made a difference. The Marines don't have that problem." -Ronald Reagan
unslow1 is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel pump wont prime 929 alan_ford Honda FireBlade 7 03-19-2014 3:13 PM
929 fuel pump wont prime OGDIDDY Honda FireBlade 21 07-30-2013 8:28 PM
929, Fuel pump wont prime afr05h33n Honda FireBlade 11 04-06-2011 12:54 PM
F4i fuel pump wont prime CBR600blaster Honda CBR 600 5 11-17-2010 5:51 AM
F4i fuel pump wont prime F4eye Honda CBR 600 0 10-12-2010 7:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome