CBR929RR Fuel priming constant - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 6 Old 02-14-2015, 5:51 AM Thread Starter
 
Join Date: 02-10-2015
Location: Ayrshire - Scotland
Posts: 242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 5
 
CBR929RR Fuel priming constant

Hey folks after watching a few you tube videos I noticed everyones blade primes the fuel for 2 seconds and then stops.

Mine keeps priming It has been sitting since 2012 and I'm currently working on it to get it MOT ready. She does start up no problems.

So has anyone had this before and or any suggestions as to what to look at?

Thanks!

Andy
acemclynch is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-16-2015, 4:12 PM Thread Starter
 
Join Date: 02-10-2015
Location: Ayrshire - Scotland
Posts: 242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 5
 
Re: CBR929RR Fuel priming constant

So the issue takes a twist!
The fuel pump was hot wired to run when the ignition was on! No fuel cut off relay under the seat just a wire cut in from the loom to supply the fuel pump

I checked the headlight relay in the plug and nothing happens when the bike is switched on. Guess that's why the mod was done.
I've removed the mod and bridged the plug using a jumper connection. That way the pump is always on but if I hit the kill switch it now turns off the pump.

I tried running the bike then disconnecting the fuel pump and the bike then cuts out.

So I'm I correct in understanding the fuel pump has to be running for the bike to operate.
It's not just for priming the injectors but also for constant supply of fuel?
acemclynch is offline  
post #3 of 6 Old 02-17-2015, 12:47 AM
 
Join Date: 11-23-2013
Location: Bangkok
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: CBR929RR Fuel priming constant

I believe that the priming is just the same as turning the throttle on a carb bike before starting. After 2 seconds, the pump stops until the bike is started so that it's not running continuously and burning out the pumpt or draining the battery if you leave the ignition on accessory. Once the bike is running, the fuel pump is constantly supplying fuel.
lust is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 02-17-2015, 11:43 AM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: CBR929RR Fuel priming constant

The pump needs to keep about 50psi supplied to the fuel rail to feed the injectors.
Check that your bank angle sensor relay is working properly, (maybe it's called engine stop relay for the 929?), it's tied into the power for your fuel cut relay.
You might test the bank angle sensor itself as well.
You might also check your fpr for any signs of leaking at the vacuum hose too. Just pull the vac hose, then get the pump to prime and make sure no leaking gas. I mentioned that because you said the bike was sitting for a spell, and it's not uncommon for the diaphragm to rot from sitting so long with fuel in it.
jondog9 is offline  
post #5 of 6 Old 02-17-2015, 12:34 PM Thread Starter
 
Join Date: 02-10-2015
Location: Ayrshire - Scotland
Posts: 242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 5
 
Re: CBR929RR Fuel priming constant

Wow in that case the fuel injector power (black cable) must also be bypassed as the bike runs fine.
Looks like from the schematic engine stop relay or lean angle sensor as you say could have a part to play why the factory setup isn't working.
Only one of the black wires to the fuel cut off relay had a voltage on it. Which could be the one from the ECU.
Either the sensors are dead or the ECU
acemclynch is offline  
post #6 of 6 Old 02-17-2015, 12:35 PM Thread Starter
 
Join Date: 02-10-2015
Location: Ayrshire - Scotland
Posts: 242
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 5
 
Re: CBR929RR Fuel priming constant

Oh I also tested the FPR and it was fine. No fuel. Plus the bike sounds great.
acemclynch is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Tags
always on , fuel pump , when priming

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
no fuel priming noise 929 mozzersaints Tools / Garage / Paddock 1 08-04-2014 2:02 AM
Fuel pump not priming Kvidalin Honda RC51 10 05-20-2010 11:47 AM
Fuel pump not priming ozerionblade Honda FireBlade 8 03-20-2008 8:22 PM
Fuel pump not priming - cause? cbr_df Honda FireBlade 60 01-10-2007 2:43 AM
priming but no fuel ? stopsign Honda FireBlade 2 11-01-2005 2:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome