Electrical problems involving FuelPump on my 03 954rr - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 20 Old 03-26-2015, 8:17 PM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Electrical problems involving FuelPump on my 03 954rr

Hopefully someone on here can give me a little more help than I'm finding. I went out to ride today and turned they key on my bike and instantly noticed the fuel pump didn't cut on. Following that I realized my headlights weren't working either, low or high beam nor the symbol on the dash. Both front and rear turn signals work on the bike both sides but the signal icons on the dash don't flash. Tail light works along with brake light. Horn works too, the dash only had two colors on when they key is turned on, green for neutral and red for what im assuming is oil. Is my fuel pump bad or is it a short somewhere? Any help would be greatly appreciated, thanks!
NastyHondas4me is offline  
Sponsored Links
Advertisement
 
post #2 of 20 Old 03-26-2015, 9:47 PM
 
Join Date: 03-18-2015
Location: amador county.
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
   
Re: Electrical problems involving FuelPump on my 03 954rr

Hello, here is what i would start with.

Pull battery and fully charge and check that it is good.

Check fuses,

check all grounds for corrosion.

Check connectors as well.

I always try to start with the basics and go from there.
If it was just the fuel pump i could see it being the tip over sensor or a bad pump but if you have other things not working to that makes me think a bad ground or bad battery. could also be a short some where or a bad ecu worst case. Good luck tracing it down.
kcdub1000 is offline  
post #3 of 20 Old 03-28-2015, 4:16 PM
Heeza Y Zasch
 
unslow1's Avatar
 
Join Date: 09-14-2008
Location: Tioga County, NY
Posts: 3,023
Mentioned: 26 Post(s)
Tagged: 3 Thread(s)
Quoted: 385 Post(s)
Reputation Power: 59
                     
Re: Electrical problems involving FuelPump on my 03 954rr

I agree with "k'dub"... but chances are the Fuel Pump Relay has expired.

I'd get ready to replace all 3 of them... or at least buy 3 and keep a spare in the "trunk".

easiest way to check is trade it out with the Headlight/HiBeam relay and test.

good luck and keep us posted.
Attached Thumbnails
P8070022DT.jpg‎   P8070025DT.jpg‎  

non-Honda fleet: EX250JAF, VL1500LC, ZX600-E1, ZX600-E12
"Some people wonder all their lives if they've made a difference. The Marines don't have that problem." -Ronald Reagan
unslow1 is offline  
Sponsored Links
Advertisement
 
post #4 of 20 Old 03-29-2015, 3:45 PM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Electrical problems involving FuelPump on my 03 954rr

Sorry was in Md for the weekend! So it's not very likely that my fuel pumps bad? It's more likely to be an electrical issue? When it first happened I charged the battery to make sure that wasn't it and its ok. I guess now it's time to pull the plastics off and start checking, will all of these fuses be fairly accessible? Thanks for the help so far guys!! Appreciate it a lot!!
NastyHondas4me is offline  
post #5 of 20 Old 03-30-2015, 6:15 PM
 
Join Date: 11-28-2014
Location: San Diego, California
Age: 33
Posts: 195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Reputation Power: 9
         
Re: Electrical problems involving FuelPump on my 03 954rr

I agree too, Sounds like your relay is stuck, its mechanical on the inside, for giggles or if you get bored.... you can cut the top off of it with a dremel and free it by hand, then file the contacts for a better connection. I did this with a Toyota Circuit opening relay, works like a charm.

2001 929RR
1993 Kawasaki KLR 650
Pablo.gyds03 is offline  
post #6 of 20 Old 03-30-2015, 11:16 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: Electrical problems involving FuelPump on my 03 954rr

^ necessity is the mother of invention
jondog9 is offline  
post #7 of 20 Old 03-31-2015, 3:43 AM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Electrical problems involving FuelPump on my 03 954rr

Well I'm just confused now, after getting the rear seat cowl off I went ahead charged the battery again just to be sure. Came out about an hr later and turned the key and I heard the fuel pump click on, bike starts, everything works. I turn it off only to find I couldn't get it to start back up again. When testing these connectors I found some didn't have a charge at all, could these be ground wires? Also when I flick my headlight switch to high beam on and off I can feel a click in one of the relay boxes, any significance to this? Where can I find these relay switches to buy? And should I test my battery to make sure it's running on the right voltage? Thanks!
NastyHondas4me is offline  
post #8 of 20 Old 03-31-2015, 3:57 AM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Electrical problems involving FuelPump on my 03 954rr

I don't know if this means anything but I recently had my ignition switch, the whole assembly switched out by Motorcycle Factory Inc in Woodbridge Va. Before that I never had any problems, the day they finished I picked my bike up and rode it home with no issues. Could there be something that went wrong when they did this?
NastyHondas4me is offline  
post #9 of 20 Old 03-31-2015, 4:45 PM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Electrical problems involving FuelPump on my 03 954rr

Battery test came up to 13.2V
NastyHondas4me is offline  
post #10 of 20 Old 04-01-2015, 4:13 PM
 
Join Date: 11-28-2014
Location: San Diego, California
Age: 33
Posts: 195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Reputation Power: 9
         
Re: Electrical problems involving FuelPump on my 03 954rr

Battery voltage looks good, Try swapping relays around to see if the problem follows, the headlight relay is the same type as the fuel pump relay.

2001 929RR
1993 Kawasaki KLR 650
Pablo.gyds03 is offline  
post #11 of 20 Old 04-07-2015, 4:24 PM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Electrical problems involving FuelPump on my 03 954rr

I'm going to make a video or take some pics cause I've come across extra wiring and an extra relay switch/: I've swapped around the 3relay switches leaving the extra alone for lack of knowledge on it. After swapping them around still no difference. I'm going to go over everything again, look for bad grounds and what not but I might have to take it somewhere. I hate having to do that bit I hate not riding more.
NastyHondas4me is offline  
post #12 of 20 Old 04-07-2015, 6:17 PM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Electrical problems involving FuelPump on my 03 954rr

Here's a quick video. Going over the dash displays, turn signals, tail lights, brake lights. Relay switches and the extra one. If this vid sends correctly ill make a better more specific one. Thanks for all the help guys
Attached Files
File Type: mov capturedvideo.MOV‎ (10.90 MB, 20 views)
NastyHondas4me is offline  
post #13 of 20 Old 04-07-2015, 6:17 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: Electrical problems involving FuelPump on my 03 954rr

It looks like your kind of stabbing around in the dark.
Do a search for a workshop manual, there are a couple available online free for the download.
Without knowing any of the previous history of the bike, or what connectors your testing, or the health of your battery, it's damn near impossible to diagnose your problem over a forum. It could be as simple as an exhausted battery - yes I know you charged it, but that doesn't give us the necessary info - or something like knackered wiring or bad grounds. You need to start with basic tests, and eliminate potential problems one at a time.
Get yourself a workshop manual, you'll save hundreds of $$ over taking it to a shop.

EDIT: ha, we posted at the same time. Anyway, I don't care to download any video to my computer. Put it on youtube or Vimeo
jondog9 is offline  
post #14 of 20 Old 04-07-2015, 7:03 PM Thread Starter
 
Join Date: 02-22-2014
Location: Springfield Virginia
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Electrical problems involving FuelPump on my 03 954rr

Hahah sure thing, just put it on Vimeo. Honda CBR 954rr 2003 electrical issues

Thanks!!!
NastyHondas4me is offline  
post #15 of 20 Old 04-07-2015, 8:17 PM
 
Join Date: 11-14-2009
Location: Morristown, Tennessee
Age: 44
Posts: 823
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Reputation Power: 56
                     
Garage
Re: Electrical problems involving FuelPump on my 03 954rr

Your problem is a short or broken wire connection in the right handlebar switch. Take it apart and check everything and see what you find.

SOLD: 03 CBR954
backdoc is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Tags
electrical problems , fuel pump issue , honda cbr 954

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problems archleonard Honda FireBlade 2 10-03-2010 1:56 PM
Electrical Problems honda freak 08 Honda FireBlade 19 02-22-2009 5:58 PM
Electrical Problems on 02 954RR, please help doogstar General Discussion 5 03-15-2008 3:44 PM
Electrical problems in my car, need help stegen Off-Topic 9 09-21-2006 5:51 PM
2002 954RR Electrical problems - no power, nada, zip, zero... ajdunlap Honda FireBlade 5 09-09-2006 3:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome