929rr motor swap won't run backfires - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 2Likes
  • 1 Post By machinehead
  • 1 Post By jondog9
 
LinkBack Thread Tools
post #1 of 10 Old 08-30-2017, 12:03 PM Thread Starter
 
Join Date: 08-30-2017
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
929rr motor swap won't run backfires

My motor went on my 929rr swapped it with a good running motor ran it in the donor bike before it was pulled got it back together was starting hard now it just backfires in the air box and shoots flames out the exhaust
Davin_robinson is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 08-30-2017, 12:48 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 929rr motor swap won't run backfires

Timing? Fuel injection issues?
Are you using the 929 ECU? If yes, has it set any codes?
How did you deal with wiring harness - did it all fit?

I've never done a swap like that, I'm sure some here have who could give better advice.
jondog9 is offline  
post #3 of 10 Old 08-30-2017, 12:55 PM Thread Starter
 
Join Date: 08-30-2017
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Same ecu same wiring everything was exact except air box
Davin_robinson is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 08-30-2017, 1:01 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 929rr motor swap won't run backfires

Well, other than the similarities to my bike, I'm kinda out of my league here. But it does sound like timing, hence the ECU question.

Edit, I misread. Sorry. Thought you planted a 954 into your 929. I see you just did a straight swap.
Reading comprehension...
jondog9 is offline  
post #5 of 10 Old 09-03-2017, 10:39 PM Thread Starter
 
Join Date: 08-30-2017
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
It was starting hard but running awesome now just the thing just backfires like that no codes display not a 100% sure on how to read them
Davin_robinson is offline  
post #6 of 10 Old 09-04-2017, 9:56 AM
 
Join Date: 03-21-2005
Location: Wiltshire, uk
Age: 53
Posts: 1,189
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Reputation Power: 20
         
Garage
Re: 929rr motor swap won't run backfires

have you made sure all the spark plugs wires are correct order? If the middle two are swapped over, which is very easy to do, it will start but may cause the back-fire you're having. Worth a look anyway.

reading codes is straight forward. Ignition and kill switch off. Short the Check connector RH side by the battery (two pin connector - make sure you've the right thing but the should only be one there!). turn the ignition on and kill switch on, do not start. The bike will power up and the MIL will flash if there are codes stored. if it stays steady red then no codes. if it flashes 6 times that code 6, 1 flash followed by a short gap and say 2 flashes is a code 12. If there is more than one fault logged there will be a long gap between the first code and the next. when it gets to the last code it will start again from the first one again. There is a table of the code in the internet, workshop manual etc. There is also a guide on how to clear the codes but I cannot remember off the top of my head.

Hope this helps.
MrPickwick likes this.
machinehead is offline  
post #7 of 10 Old 09-04-2017, 11:01 AM
Supporting Member
 
Join Date: 12-21-2015
Location: Lancs ,UK
Posts: 2,000
Mentioned: 15 Post(s)
Tagged: 1 Thread(s)
Quoted: 487 Post(s)
Reputation Power: 0
                     
Garage
Re: 929rr motor swap won't run backfires

Quote:
Originally Posted by machinehead View Post
have you made sure all the spark plugs wires are correct order? If the middle two are swapped over, which is very easy to do, it will start but may cause the back-fire you're having. Worth a look anyway.

reading codes is straight forward. Ignition and kill switch off. Short the Check connector RH side by the battery (two pin connector - make sure you've the right thing but the should only be one there!). turn the ignition on and kill switch on, do not start. The bike will power up and the MIL will flash if there are codes stored. if it stays steady red then no codes. if it flashes 6 times that code 6, 1 flash followed by a short gap and say 2 flashes is a code 12. If there is more than one fault logged there will be a long gap between the first code and the next. when it gets to the last code it will start again from the first one again. There is a table of the code in the internet, workshop manual etc. There is also a guide on how to clear the codes but I cannot remember off the top of my head.

Hope this helps.
^^^
MrPickwick is offline  
post #8 of 10 Old 09-04-2017, 2:04 PM
 
Join Date: 01-08-2011
Location: Northern CA
Posts: 7,455
Mentioned: 6 Post(s)
Tagged: 2 Thread(s)
Quoted: 120 Post(s)
Reputation Power: 198
                     
Re: 929rr motor swap won't run backfires

Try using a period every once in awhile.
chuckhunter likes this.
jondog9 is offline  
post #9 of 10 Old 09-04-2017, 8:01 PM
Supporting Member
 
chuckhunter's Avatar
 
Join Date: 07-11-2016
Location: Buffalo, NY
Posts: 313
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Reputation Power: 10
           
Re: 929rr motor swap won't run backfires

^^
chuckhunter is offline  
post #10 of 10 Old 09-10-2017, 12:47 PM
 
Join Date: 03-21-2005
Location: Wiltshire, uk
Age: 53
Posts: 1,189
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Reputation Power: 20
         
Garage
Re: 929rr motor swap won't run backfires

Quote:
Originally Posted by jondog9 View Post
Try using a period every once in awhile.
I'll go get the Mrs but not sure how her periods help with bad engine running though?>
machinehead is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Bike won't run brendonmgg Honda CBR 600 4 10-24-2016 1:37 PM
'93 900RR won't always run AfghanStyle Honda FireBlade 8 07-19-2011 10:39 PM
01 929RR - Won't run, fuel dripping satvic Honda FireBlade 27 02-15-2009 7:54 PM
Engine won't run scuba14c Honda Interceptor / VFR 2 07-21-2007 11:52 AM
WON'T RUN DANIEL General Discussion 9 05-18-2007 1:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome