CBR 929 choking out going from idle to WOT, seems to be dropping cylinders - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 11 Old 07-23-2019, 11:44 AM Thread Starter
 
Join Date: 08-15-2013
Location: North Dakota
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
CBR 929 choking out going from idle to WOT, seems to be dropping cylinders

I have been chasing my tail on this one for awhile and can't seem to figure it out. The bike idles fine and runs great when on the gas hard but when going from idle to WOT, it stumbles and seems to drop a cylinder or two before snapping out of it and coming back on and running strong again all the way to the rev limiter. Any ideas what this could be? I have tried most/all potential electrical/fuel issues coils, injectors, ecu, stator, plugs, harnesses, sensors, fpr, etc. Could it be a timing issue or valve clearance issue? Any help or thoughts are appreciated very much. Thank you

Last edited by jkjel15; 08-12-2019 at 12:27 PM.
jkjel15 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 07-24-2019, 3:30 AM
 
Join Date: 06-28-2018
Location: Lichfield, Staffordshire, UK
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

Be take it to a dyno to diagnose that, could be expensive though
Mustang is offline  
post #3 of 11 Old 07-25-2019, 11:08 AM Thread Starter
 
Join Date: 08-15-2013
Location: North Dakota
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

Quote:
Originally Posted by Mustang View Post
Be take it to a dyno to diagnose that, could be expensive though
Dyno is my next step if no one has any ideas. Could a vacuum line issue cause this?
jkjel15 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 07-25-2019, 1:53 PM
 
Join Date: 10-26-2015
Location: Massachusetts
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

Possibly the servo?
HEROrr is offline  
post #5 of 11 Old 07-27-2019, 7:13 AM
 
Join Date: 04-30-2015
Location: Stevenston, North Ayrshire, Scotland
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

Check HTEV is calibrated and working properly.
ilyamomorte is offline  
post #6 of 11 Old 07-27-2019, 11:09 PM
 
Join Date: 01-04-2010
Location: Athens Ohio
Posts: 170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Reputation Power: 10
 
I would just replace all the vacuum lines. It’s really easy it took me about an hour to do. I’m wrapping up my rebuild right now and that was the easiest part of the entire process
msf0002 is offline  
post #7 of 11 Old 08-06-2019, 2:48 PM Thread Starter
 
Join Date: 08-15-2013
Location: North Dakota
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

Quote:
Originally Posted by HEROrr View Post
Possibly the servo?
Thank you, HTEV/servo have previously been eliminated on this bike.
jkjel15 is offline  
post #8 of 11 Old 08-06-2019, 2:48 PM Thread Starter
 
Join Date: 08-15-2013
Location: North Dakota
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

Quote:
Originally Posted by msf0002 View Post
I would just replace all the vacuum lines. Itís really easy it took me about an hour to do. Iím wrapping up my rebuild right now and that was the easiest part of the entire process
May give that a try just in case, thanks
jkjel15 is offline  
post #9 of 11 Old 08-06-2019, 4:41 PM
 
Join Date: 09-09-2010
Location: Somewhere
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

My 954 was running really rough at mid-RPM a few weeks ago. I noticed that the blinker rate was also very erratic when it was running rough. I suspected that the regulator was putting out an unstable voltage, messing with the injectors etc.

I changed the regulator and the bike has been running beautifully since. Maybe it's worth some effort for you to check whether the regulator output is stable?
kame is offline  
post #10 of 11 Old 08-06-2019, 4:55 PM Thread Starter
 
Join Date: 08-15-2013
Location: North Dakota
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: CBR 929 Stumbling in Mid Range, Runs Good on Top, seems to be dropping cylinders

Quote:
Originally Posted by kame View Post
My 954 was running really rough at mid-RPM a few weeks ago. I noticed that the blinker rate was also very erratic when it was running rough. I suspected that the regulator was putting out an unstable voltage, messing with the injectors etc.

I changed the regulator and the bike has been running beautifully since. Maybe it's worth some effort for you to check whether the regulator output is stable?
Will give it a shot, I think I have swapped the regulator from my parts bike but have not actually verified the output is stable. Thanks
jkjel15 is offline  
post #11 of 11 Old 08-12-2019, 1:18 AM Thread Starter
 
Join Date: 08-15-2013
Location: North Dakota
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Replaced vacuum lines and no difference. When going from idle to WOT on the stand it falls flat and then wakes back up, almost like 2-3 cylinders are shutting off and then coming back on. Would throttle bodies not being synced cause this or would that only affect the idle?
jkjel15 is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome