Problem with my 954's alternator? - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 10 Old 07-20-2008, 6:12 PM Thread Starter
 
Join Date: 06-06-2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Problem with my 954's alternator?

So I am riding down the road and my spedometer shuts off like i turned the key and my tach went down to 0 showing me at no rpms even when I rev. So I pull over and mess with it a little and try shutting it off and starting it back up, But bad idea..it didn't start again.

Luckily a friend of mine with a 954 showed up to help

So we mess around with it a little, we check the fuses and such, but they all looked fine. So we take the battery out of his bike and put it in mine and it starts right up, I run home with it and come back in my car. By then he had gotten his bike started with my dead battery from push starting it. He road around a bike and it seemed to keep the battery charged up fine.

I disconnected his charged batter as soon as I got home, I figured if it is the alternator I dont want it to kill this battery too and need to charge it.


Anyways, I went to a bike shop and explained them them what happened and they said it didnt sound like the alternator to them. They said they think something may have shorted out. They said to make an appointment and get it diagnosed.

SO..I come here in hopes someone can give me some ideas.
Origin is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 07-20-2008, 6:25 PM
Global Moderator
 
Join Date: 05-01-2006
Posts: 5,652
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 198 Post(s)
Reputation Power: 25
           
Re: Problem with my 954's alternator?

It is either the stator or the Regulator/Rectifier. Most likely, it is the regulator. You can test both of them:
Technical Resources Library - ElectroSport Industries
lanbrown is offline  
post #3 of 10 Old 07-20-2008, 7:16 PM
 
Join Date: 12-21-2006
Location: Greece
Age: 39
Posts: 251
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 13
 
Re: Problem with my 954's alternator?

it could be the r/r and (or) stator.Just happened to me,exact same thing,it is the stator,i am waiting for a new one.Just search the forum for stator and you would be surprised how often it is.
babisgr is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 07-20-2008, 8:03 PM
 
Join Date: 11-25-2007
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Problem with my 954's alternator?

ya the plug from the rectifier just dosent hold the amps and the copper connecters will get hot enough to burn the plastic connecter housing. if you look at it and it is discolored from heat it will keep on eating batteries and rectifiers. i soldered them and used shrink tube along with a final wrap of electrical tape. no more heat build up. i think i also saw somthing about this here and some one had a different solution but cant recall.
jj_long is offline  
post #5 of 10 Old 07-20-2008, 8:33 PM
 
Join Date: 12-29-2006
Location: va
Posts: 258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 13
 
Re: Problem with my 954's alternator?

i had the same exact problem happen to my 929 twice!

the first time it was the was just worn out.
the second time, it was a unit from electromotorsports and it fried after 1500 miles, i replaced it with a unit from GDL cycles out of florida and all problems solved.

now the unit i got from electromotorsports got burned out right around by the stator and chared those wires

the unit i got from GDL cycles already had the connector on it so it was a replace and plug, no sodering.

i would recommend them over electomotorsports

like 160 shipped and that was the stator and gasket! and about 2hrs of your time with the oil change.
bignibb is offline  
post #6 of 10 Old 07-20-2008, 8:36 PM
 
Join Date: 12-29-2006
Location: va
Posts: 258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 13
 
Re: Problem with my 954's alternator?

now my unit from electormotorsports was under warranty so they will be sending me a new replacement so if anyone is interested in it let me know before it hits ebay.
bignibb is offline  
post #7 of 10 Old 07-21-2008, 7:04 AM
 
Join Date: 12-21-2006
Location: Greece
Age: 39
Posts: 251
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 13
 
Re: Problem with my 954's alternator?

just bought one from ebay "cycletherapy" ,not the cheapest arround,but not all send international.Lets holpe it will last some time,if not,i am going for the oem one.It lasted for 43.000km...
babisgr is offline  
post #8 of 10 Old 07-21-2008, 8:53 AM
 
Join Date: 06-06-2006
Location: Newbury, Uk
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 14
 
Re: Problem with my 954's alternator?

My stator went a few weeks ago and when it's not charging properly the battery charge can get so low the clocks switch off and the rev counter drops to zero.
dern is offline  
post #9 of 10 Old 07-21-2008, 7:11 PM Thread Starter
 
Join Date: 06-06-2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: Problem with my 954's alternator?

How hard is it to do the work myself to replace the stator. I can't find my multimeter so a friend is lending me his. Once I can do the tests and be 100% sure its the stator I will order one.

Thank you all very much for the help.
Origin is offline  
post #10 of 10 Old 07-21-2008, 7:32 PM
 
Join Date: 12-29-2006
Location: va
Posts: 258
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 13
 
Re: Problem with my 954's alternator?

its real easy, if you drain the oil and do an oil change at the same time, it should take no longer than 2 hrs from start to finish.
bignibb is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with my usb Pc3usb Techguy Honda FireBlade 3 06-12-2008 5:35 AM
HELP! Alternator problem? 93 900rr importnoodles Honda FireBlade 3 04-16-2008 10:33 PM
Problem with starting up my bike rodrigoblanco Honda CBR 600 11 06-06-2007 1:07 AM
BIG PROBLEM WITH MY ERION 20blks Honda FireBlade 10 07-11-2006 8:04 PM
INJECTION PROBLEM WITH MY '00 929RR ??? jfboy Honda FireBlade 19 08-29-2004 3:47 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome