954 Runs like garbage and dies - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 24 Old 06-22-2010, 7:21 PM Thread Starter
 
Join Date: 06-22-2010
Location: okc
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
954 Runs like garbage and dies

I am having problems with my 954. I left it sitting all winter and now want to enjoy the nice weather. Battery was dead so i tried to jump start it and it starts after lots of cranking on the starter but runs like garbage. Anytime you give it any gas it boggs down and dies. and if u let it idle it will die with in a couple of min. after reading on this forum i thought i have a faulty TPS senor or FPR. I replaced the whole throttle body set including injectors, FPR and TPS and vaccum lines etc.(i bought them used). I checked and cleaned the plugs. and still having the same problem. I have the airbox still off trying to troubleshoot it. Whats next to replace or test? Any input would appreciated!!
mcgee.cody is offline  
Sponsored Links
Advertisement
 
post #2 of 24 Old 06-22-2010, 7:27 PM
 
Join Date: 07-02-2008
Location: Seattle
Age: 31
Posts: 2,517
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 78
                     
Re: 954 Runs like garbage and dies

Its surely bad gas.
BurtonF166 is offline  
post #3 of 24 Old 06-22-2010, 7:38 PM
 
Join Date: 09-23-2009
Location: Charlotte, NC
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

If you replaced the throttle bodies you will likely need to have them synched to your motor. This is done using a sychronizing vacum tool. Also make sure you charge your battery all the way. Although if the battery was the problem you should not notice it until you disconect the jumpers. Last just like he said earlier replace the gas and maybe add some seafoam to the gas. Good luck!
honda50 is offline  
Sponsored Links
Advertisement
 
post #4 of 24 Old 06-22-2010, 7:43 PM Thread Starter
 
Join Date: 06-22-2010
Location: okc
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

I have replaced the gas and ran a can of seafoam with it. I have been jump starting tHe bike with an extra battery I have in my garage. Sync the tb with the motor by checking the vaccum pressure at each cylinder?
mcgee.cody is offline  
post #5 of 24 Old 06-22-2010, 7:56 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 230
                     
Re: 954 Runs like garbage and dies

Quote:
Originally Posted by mcgee.cody View Post
I am having problems with my 954. I left it sitting all winter and now want to enjoy the nice weather. Battery was dead so i tried to jump start it and it starts after lots of cranking on the starter but runs like garbage. Anytime you give it any gas it boggs down and dies. and if u let it idle it will die with in a couple of min. after reading on this forum i thought i have a faulty TPS senor or FPR. I replaced the whole throttle body set including injectors, FPR and TPS and vaccum lines etc.(i bought them used). I checked and cleaned the plugs. and still having the same problem. I have the airbox still off trying to troubleshoot it. Whats next to replace or test? Any input would appreciated!!

Did you actually check the FPR?
Did you drain the old fuel and replace it with fresh stuff?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #6 of 24 Old 06-22-2010, 7:56 PM
 
Join Date: 07-02-2008
Location: Seattle
Age: 31
Posts: 2,517
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 78
                     
Re: 954 Runs like garbage and dies

With the airbox off, youll get a fault code for the IAT sensor which can cause issues
BurtonF166 is offline  
post #7 of 24 Old 06-22-2010, 8:09 PM
 
Join Date: 09-23-2009
Location: Charlotte, NC
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

Also since you where pulling on and off the vacum lines make sure none of them are cracked or leaking. When you start it, does it stumble up high or just down low in the rpm range? You do synch the throttle bodies with the engine running by connecting a vacum hydrometer to each cylinder all at the same time and synching them to match.
honda50 is offline  
post #8 of 24 Old 06-22-2010, 8:23 PM Thread Starter
 
Join Date: 06-22-2010
Location: okc
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

I pulled the vaccum line off the side of the fpr and no gas is coming out. I drained all the gas out and put new gas and seafoam in the tank. I have not synced the tb. I will read more info on it and go buy a vaccum guage. The iat sensor is pluged in just not in the air box. I have no error codes.
mcgee.cody is offline  
post #9 of 24 Old 06-22-2010, 8:33 PM Thread Starter
 
Join Date: 06-22-2010
Location: okc
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

I looked at all the vaccum lines and they look fine, no cracks or anything.
I lost the key to the bike, so i pulled off the bottom of the ignition switch and am using that to start the bike. the diode on it was broke so i sodered a 2000 ohm resistor on the bottom of it.(Pink wire). i dont this will have anything to do with it running like crap but thought i should give u all the info.
mcgee.cody is offline  
post #10 of 24 Old 06-22-2010, 8:52 PM
 
Join Date: 04-16-2006
Location: Middessa Tx
Posts: 1,640
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 17
     
Re: 954 Runs like garbage and dies

Quote:
Originally Posted by BurtonF166 View Post
Its surely bad gas.
rokitt51 is offline  
post #11 of 24 Old 06-22-2010, 9:38 PM Thread Starter
 
Join Date: 06-22-2010
Location: okc
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

I'll try gas again. I'll go get some 93 and fill it up. I'll post results
mcgee.cody is offline  
post #12 of 24 Old 06-23-2010, 2:32 AM Thread Starter
 
Join Date: 06-22-2010
Location: okc
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

Fresh tank of gas no help. Started it, idle, die. Did it a couple times. Checked resistance on the tps, good. Pulled the sparkplugs seem fine but will post pics of them when I'm not on my phone. From what I've read the bike has to be running to sync the tb's. I can't get it to idle long enough to do that. Any other ideas?
mcgee.cody is offline  
post #13 of 24 Old 06-23-2010, 2:40 AM
 
Join Date: 07-02-2008
Location: Seattle
Age: 31
Posts: 2,517
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 78
                     
Re: 954 Runs like garbage and dies

unless the TBs have been messed with prior, there should not be a sync issue.

At what rpm is it idling?
BurtonF166 is offline  
post #14 of 24 Old 06-23-2010, 3:15 AM Thread Starter
 
Join Date: 06-22-2010
Location: okc
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 954 Runs like garbage and dies

Idle is at about 1k to 1.5k. I have played with the idle adjuster. Even if I set the idle higher it still does the same thing. Very hard to start, rough idle for a min then dies. Bad ecu??
mcgee.cody is offline  
post #15 of 24 Old 06-23-2010, 3:22 AM
 
Join Date: 07-02-2008
Location: Seattle
Age: 31
Posts: 2,517
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 78
                     
Re: 954 Runs like garbage and dies

Quote:
Originally Posted by mcgee.cody View Post
Idle is at about 1k to 1.5k. I have played with the idle adjuster. Even if I set the idle higher it still does the same thing. Very hard to start, rough idle for a min then dies. Bad ecu??
Sounds right.
Do you have a power commander?
ECU would be the very last thing to check, especially if it just sat for 6 months.
Did you by chance hook up some of the injectors on the new TBs up incorrectly?
BurtonF166 is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bike runs fine and then dies after a while ecd2004 Honda CBR 600 21 04-17-2017 8:55 AM
1995 900RR Runs Good Then Runs Bad eetchickn General Discussion 2 03-17-2009 9:57 PM
93 cbr 600 starts hard then runs and dies help honda4life251 Honda CBR 600 3 05-23-2008 9:01 PM
bike runs fine,dies and won't restart CBR629 Honda RC51 1 05-15-2008 10:07 PM
Garbage Can Surprise Chain Off-Topic 3 03-12-2005 6:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome