929, Fuel pump wont prime - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 12 Old 02-14-2011, 9:10 AM Thread Starter
 
Join Date: 09-09-2010
Location: Florida
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
929, Fuel pump wont prime

Hey whats up guys. I recently landed hard on the left side of my 929, pulverizing the stator cover and that side of the crankcase. It sat for about a month and then after swapping the motor I attempted to start it, but the fuel pump is not priming. It cranks strong but no start, will make a few puffs of smoke on ether. Ive checked the fuses and fuel pump but they're all good. Can anyone steer me in the right direction? I wanna ride!!!
afr05h33n is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 02-14-2011, 9:25 AM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 929, Fuel pump wont prime

Quote:
Originally Posted by afr05h33n View Post
Hey whats up guys. I recently landed hard on the left side of my 929, pulverizing the stator cover and that side of the crankcase. It sat for about a month and then after swapping the motor I attempted to start it, but the fuel pump is not priming. It cranks strong but no start, will make a few puffs of smoke on ether. Ive checked the fuses and fuel pump but they're all good. Can anyone steer me in the right direction? I wanna ride!!!

You swapped in a new engine that you haven't yet managed to run at all?
Have you confirmed you have spark?
Is the bank angle sensor mounted correctly and connected?
Is it flashing any error codes?
Without the fuel pump it won't fire as it needs pressure to operate the injectors. Try running power directly to the pump and see if it fires then.

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #3 of 12 Old 02-14-2011, 10:59 AM Thread Starter
 
Join Date: 09-09-2010
Location: Florida
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 929, Fuel pump wont prime

Its not flashing any error codes but it does have spark. I tried running power to the fuel pump but the engine will only sputter and stop almost immediately after i stop pressing the ignition button. the bank angle sensor was mounted correctly i think but i haven't checked to make sure its definitely connected properly. thanks
afr05h33n is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 02-14-2011, 11:52 AM
 
Join Date: 09-10-2008
Location: florida
Posts: 152
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 12
 
Re: 929, Fuel pump wont prime

make sure its not stuck..sometimes after a fall they get hung up...check your side stand switch too..you never know..iam guessing youve got some kind of spark for it to sputter and puff some..but is it strong?
ZeroKool929 is offline  
post #5 of 12 Old 02-14-2011, 7:15 PM
 
Join Date: 05-15-2009
Location: Mt Washington, KY
Age: 43
Posts: 567
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 16
           
Send a message via Yahoo to unfetteredmight
Re: 929, Fuel pump wont prime

Quote:
Originally Posted by afr05h33n View Post
Its not flashing any error codes but it does have spark. I tried running power to the fuel pump but the engine will only sputter and stop almost immediately after i stop pressing the ignition button. the bank angle sensor was mounted correctly i think but i haven't checked to make sure its definitely connected properly. thanks
That sounds troublesome. If you have spark and you can't get it to run on starting fluid, then run a compression check.
unfetteredmight is offline  
post #6 of 12 Old 02-14-2011, 10:34 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 929, Fuel pump wont prime

Quote:
Originally Posted by afr05h33n View Post
Its not flashing any error codes but it does have spark. I tried running power to the fuel pump but the engine will only sputter and stop almost immediately after i stop pressing the ignition button. the bank angle sensor was mounted correctly i think but i haven't checked to make sure its definitely connected properly. thanks


I asked before, have you run this engine at all?
Have you checked the compression and/or valve clearances?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #7 of 12 Old 02-15-2011, 11:32 AM Thread Starter
 
Join Date: 09-09-2010
Location: Florida
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 929, Fuel pump wont prime

No i havent run the engine at all nor checked compression or valve clearances, i took the word of the guy i got it from that it would be in proper functioning order.
afr05h33n is offline  
post #8 of 12 Old 02-15-2011, 11:36 AM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 929, Fuel pump wont prime

Quote:
Originally Posted by afr05h33n View Post
No i havent run the engine at all nor checked compression or valve clearances, i took the word of the guy i got it from that it would be in proper functioning order.

Then it's probably worth doing a compression test to confirm that it is good. Was any reason given for why the engine was removed from the bike originally or how long it was sitting?
When you said if "puffed" I'm assuming you mean it didn't actually fire?

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #9 of 12 Old 02-15-2011, 1:36 PM Thread Starter
 
Join Date: 09-09-2010
Location: Florida
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 929, Fuel pump wont prime

I got the engine off ebay from a very reputable seller and it was from a light collision bike but the engine was in immaculate condition. I dont know how long it was sitting, but certainly several months at the least. No it wouldnt actually fire even with the fuel pump getting direct power, just generated a few puffs of exhaust as i pressed the ignition button and not the normal roar im used to.
afr05h33n is offline  
post #10 of 12 Old 02-15-2011, 1:41 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 229
                     
Re: 929, Fuel pump wont prime

Quote:
Originally Posted by afr05h33n View Post
I got the engine off ebay from a very reputable seller and it was from a light collision bike but the engine was in immaculate condition. I dont know how long it was sitting, but certainly several months at the least. No it wouldnt actually fire even with the fuel pump getting direct power, just generated a few puffs of exhaust as i pressed the ignition button and not the normal roar im used to.

You need to confirm you have spark then.

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #11 of 12 Old 02-15-2011, 3:09 PM Thread Starter
 
Join Date: 09-09-2010
Location: Florida
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 929, Fuel pump wont prime

Alright thanks bladeracer
afr05h33n is offline  
post #12 of 12 Old 04-06-2011, 12:54 PM Thread Starter
 
Join Date: 09-09-2010
Location: Florida
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
 
Re: 929, Fuel pump wont prime

Finally got the blade running, traced the problem back to a back connection to the starter
afr05h33n is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
rc has no fi light and fuel pump wont prime fade28 Honda RC51 11 01-13-2011 4:08 PM
F4i fuel pump wont prime CBR600blaster Honda CBR 600 5 11-17-2010 5:51 AM
F4i fuel pump wont prime F4eye Honda CBR 600 0 10-12-2010 7:20 AM
no fuel pump prime coffeeman690 Honda CBR 600 5 10-08-2009 10:23 PM
No fuel Pump prime esmarts Honda FireBlade 3 09-17-2008 6:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome