954 Fuel Pump/Charging System Question - Honda Motorcycles - FireBlades.org
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

User Tag List

 
LinkBack Thread Tools
post #1 of 3 Old 01-23-2012, 11:09 PM Thread Starter
 
Join Date: 02-20-2006
Location: Dallas, TX
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
   
954 Fuel Pump/Charging System Question

So I was riding my '02 954 on Friday when all of a sudden it starts sputtering and the engine cut out...as if it were running out of gas. And of course this happens right at the 121/635 merge, in the middle of all of the construction North of DFW airport. I pull over onto the 18" shoulder and, sure enough, the fuel pump isn't kicking on when I turn the key and/or try the run/off button on the right handlebar. ****.

So I try a couple of friends with trucks and even call to see if I had towing on my insurance (no dice). I turn the key one last time, and I hear the fuel pump kick on. I start it and ride it about 1.5miles before it sputters and dies again. I pull over, and try monkeying with the wiring loom, but nothing. After a few minutes, the pump kicks back on and I ride about another 1/4 mile before it dies again. At that point I said **** it.

I got it home and put a volt meter on the fuel pump. I figure if the fuel pump is getting full voltage and not working, then I need a new fuel pump. But if it's not getting 12V, then it's something in between the battery and the pump. Makes sense, right?

So as I'm starting to check it, I find roughly 13V at the battery, and around 10V at the fuel pump. I try the key, on/off, on/off, and the pump kicks back on. I put the meter on the pump, and it's almost 13V. I keep it on as the bike runs, and sure enough, the bike starts to sputter and the volts drop to 12, then 11, then 10 and the bike dies.

So anyone know what the **** is going on with this thing? Something in the stator? It just seems like the fuel pump isn't getting enough voltage to stay running, so it doesn't seem like simply swapping out the pump is going to do anything. I wish it were that easy. Anyone have any suggestions??

Thanks.
BigJasonRR is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-23-2012, 11:16 PM
Global Moderator
 
bladeracer's Avatar
 
Join Date: 11-14-2003
Location: Perth, WestOz
Age: 53
Posts: 32,034
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Reputation Power: 230
                     
Re: 954 Fuel Pump/Charging System Question

Quote:
Originally Posted by BigJasonRR View Post
So I was riding my '02 954 on Friday when all of a sudden it starts sputtering and the engine cut out...as if it were running out of gas. And of course this happens right at the 121/635 merge, in the middle of all of the construction North of DFW airport. I pull over onto the 18" shoulder and, sure enough, the fuel pump isn't kicking on when I turn the key and/or try the run/off button on the right handlebar. ****.

So I try a couple of friends with trucks and even call to see if I had towing on my insurance (no dice). I turn the key one last time, and I hear the fuel pump kick on. I start it and ride it about 1.5miles before it sputters and dies again. I pull over, and try monkeying with the wiring loom, but nothing. After a few minutes, the pump kicks back on and I ride about another 1/4 mile before it dies again. At that point I said **** it.

I got it home and put a volt meter on the fuel pump. I figure if the fuel pump is getting full voltage and not working, then I need a new fuel pump. But if it's not getting 12V, then it's something in between the battery and the pump. Makes sense, right?

So as I'm starting to check it, I find roughly 13V at the battery, and around 10V at the fuel pump. I try the key, on/off, on/off, and the pump kicks back on. I put the meter on the pump, and it's almost 13V. I keep it on as the bike runs, and sure enough, the bike starts to sputter and the volts drop to 12, then 11, then 10 and the bike dies.

So anyone know what the **** is going on with this thing? Something in the stator? It just seems like the fuel pump isn't getting enough voltage to stay running, so it doesn't seem like simply swapping out the pump is going to do anything. I wish it were that easy. Anyone have any suggestions??

Thanks.

If you use the kill switch regularly my guess is it's worn out.

"I won't forget that ride for a while. Maybe you're right. Living fast might be worth the final crash. Maybe that's the secret you fliers know." - Flight of the Intruder
bladeracer is offline  
post #3 of 3 Old 01-24-2012, 10:20 AM Thread Starter
 
Join Date: 02-20-2006
Location: Dallas, TX
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Reputation Power: 0
   
Re: 954 Fuel Pump/Charging System Question

Thanks, I'll take it apart and inspect it. I may even have a spare, actually.
BigJasonRR is offline  
Reply

  Lower Navigation
Go Back   Honda Motorcycles - FireBlades.org > Honda Motorcycle Models > Honda FireBlade

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Charging System Question loknload Honda FireBlade 11 03-09-2016 11:46 PM
CHARGING SYSTEM QUESTION!!! EZCBR Honda FireBlade 38 08-10-2011 5:13 PM
Is it the Fuel pump or the electrical system? Doubletakepits Honda FireBlade 5 12-03-2009 3:56 AM
Yet another fuel pump question KVR General Discussion 2 05-10-2009 1:55 AM
Fuel Pump question benlg81 Honda FireBlade 2 01-21-2009 8:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome