Honda Motorcycles - FireBlades.org - Reply to Topic
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

Thread: 929 cuts out at redline hard to start...help Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-16-2011 10:05 PM
masterblade929
Re: 929 cuts out at redline hard to start...help

dayum, now my high beam headlights are not working...hahahahahaha...i guess i will have to buy a new relay to replace the bumbed relay i put there from the fuel shut off relay...just thought id add that there...
06-16-2011 10:02 PM
masterblade929
Re: 929 cuts out at redline hard to start...help

thanks alot...i am very pleased to have found it...i have regained confidence in the bike again...
06-16-2011 2:42 PM
shittyarsedmonk
Re: 929 cuts out at redline hard to start...help

Ooops! Read the whole thread before you post a reply! Glad to hear you've sorted it.
06-16-2011 2:38 PM
shittyarsedmonk
Re: 929 cuts out at redline hard to start...help

Does it have an alarm fitted? I had similar symptoms with a faulty alarm, although my bike cut out in the mid range when accelerating. When the alarm was removed it ran fine. Maybe it's a dodgy bank sensor, it's function is to cut the fuel supply when the bike is on it's side(I think).
06-16-2011 7:49 AM
masterblade929
Re: 929 cuts out at redline hard to start...help

Quote:
Originally Posted by bladeracer View Post
Did you check the fuel pressure regulator as I mentioned before?

Ya i did, and it tested to be fine...so last night i got to thinking about the bikes cituation real hard...i was convinced that whatever was controlling the operation of the fuel pump/fuel injectors was the cause of the issue...i managed to find a manual from a friend...i looked hard at the schematics so i could get an understanding of the operating systems of the bike...then it hit me...when i saw it in the schematic..."FUEL CUT OFF RELAY"...right away i said to myself...thats it. so i took it out did some checks as per the manual...but all checked to be fine. well it would given that the problem only happens when a load is placed on the bike. so i removed the headlight relay., switched it with the fuel cut off relay. after i had the bike back together i turned it on and noticed i had no high beam headlights. switched to low back to high, still nothing then all of a sudden the high beam lights came back...so i guess my hunch was right, the relay was opening when it shouldnt be...i took it for a run and guess what,,,perfect. the bike is fixed. i can now rev the **** out of it. it performs perfectly...i am now happy with the bike again...thanks so much for all your help and support. i hope this will some day help someone else who might have a similar problem...cheers
06-15-2011 11:33 AM
bladeracer
Re: 929 cuts out at redline hard to start...help

Did you check the fuel pressure regulator as I mentioned before?
06-15-2011 11:31 AM
bladeracer
Re: 929 cuts out at redline hard to start...help

Quote:
Originally Posted by masterblade929 View Post
ok, here i am again...i was out for a ride last night. the bike still cuts out, i noticed that it is not necessarily at redline but somewhere close to that...now get this...the fi light comes on, and...i noticed lasy night that when i try to start it, the fuel pump prime is not working when i turn on the kill switch on the right side handle controll...not only that i have a new battery and it seems it drains quickly...mmmm, bad new battery/ or is there something draining it...now after fooling with it. all of a sudden the fuel pump prime cuts in again and way to go,,,she will fire and work fine again...so i am thinking either the fuel pump is failing or whatever controlls it is malfunctioning...cause normally when it cuts out it will restart right away, but last night i had difficulty...what do you think of that...fuel pump failing????????????????

Is the light coming on simply due to the engine cutting out though?
Your killswitch should always be on. If you use it regularly then it's certainly possible for it to be failing.
Is the battery draining or is it not charging?
Did you check the charging system when you bought the battery?
06-15-2011 10:23 AM
backinblack
Re: 929 cuts out at redline hard to start...help

SO is it the red indicator light or the the FI indicator? If the red light, any flashes, or just "ON"?

Man that sucks bro..just got an '01 and the lights flash, but it's due to mods, and not a problem.
06-15-2011 7:38 AM
masterblade929
Re: 929 cuts out at redline hard to start...help

Quote:
Originally Posted by bladeracer View Post
Why haven't you got a manual for your bike?
You can see the FPR between the tank and the frame rail on the left side of the fuel rail. Pull the vacuum line, turn the ignition on to pressurise the rail, if fuel comes out you need a new FPR.
ok, here i am again...i was out for a ride last night. the bike still cuts out, i noticed that it is not necessarily at redline but somewhere close to that...now get this...the fi light comes on, and...i noticed lasy night that when i try to start it, the fuel pump prime is not working when i turn on the kill switch on the right side handle controll...not only that i have a new battery and it seems it drains quickly...mmmm, bad new battery/ or is there something draining it...now after fooling with it. all of a sudden the fuel pump prime cuts in again and way to go,,,she will fire and work fine again...so i am thinking either the fuel pump is failing or whatever controlls it is malfunctioning...cause normally when it cuts out it will restart right away, but last night i had difficulty...what do you think of that...fuel pump failing????????????????
05-30-2011 10:08 PM
masterblade929
Re: 929 cuts out at redline hard to start...help

thanks bladeracer, i will give that a try the first chance i get. is there any particular line i gotta remove. i guess its just the one line there. thanks again. it seems you wanna help me resolve this issue. i really appreciate it. and no, i dont have a manual. pretty stupid i know. and my bike is better than mint condition, and is why i am not bringing it to any shops so it will get damaged or scratched, i am very particular...
05-26-2011 2:47 AM
bladeracer
Re: 929 cuts out at redline hard to start...help

Quote:
Originally Posted by masterblade929 View Post
no, i cannot see it being an electrical connector because as i said it will happen even when on its stand, not shifting, not even in motion. yes we have switched bikes and it does it for them, you can revv the hell outta theirs and it will not happen there is something wrong, i am convinced...mmmmn, vacuum line to fuel pressure regulator, where would that be, any suggestions on the area where a problem may be with this line...thanks for your interest, and thanks for your replies.


Why haven't you got a manual for your bike?
You can see the FPR between the tank and the frame rail on the left side of the fuel rail. Pull the vacuum line, turn the ignition on to pressurise the rail, if fuel comes out you need a new FPR.
05-26-2011 2:45 AM
BallztoTheWallz
Re: 929 cuts out at redline hard to start...help

Fuel pump not supplying efficient pressure for the higher rpms and failing?
05-25-2011 10:24 PM
masterblade929
Re: 929 cuts out at redline hard to start...help

no, i cannot see it being an electrical connector because as i said it will happen even when on its stand, not shifting, not even in motion. yes we have switched bikes and it does it for them, you can revv the hell outta theirs and it will not happen there is something wrong, i am convinced...mmmmn, vacuum line to fuel pressure regulator, where would that be, any suggestions on the area where a problem may be with this line...thanks for your interest, and thanks for your replies.
05-25-2011 11:27 AM
bladeracer
Re: 929 cuts out at redline hard to start...help

Quote:
Originally Posted by masterblade929 View Post
thats easier said than done. now when i say it cuts out when it hits redline it is roughly in that range. its right at the peak of changing gears so it is not predictable...thats the problem i have. it is not normal... i dont like it and want to fix it. for example. if it is sitting on the side stand after it is warmed up and even then if i rev it up, high rpm i might add, it will cut out. my two buddies have the exact bikes, and it does not happen to theirs...i may try switching computers and see if i can duplicate it then...i just dunno...im frustrated.

If it's not consistant maybe it's a loose electrical connector that's moving as you make the shifts. If you ride it hard but shift gears at 10,000rpm does it do it? If your buddies ride your bike do they have the same problem?
Have you checked the vacuum line to the fuel pressure regulator?
05-25-2011 10:17 AM
masterblade929
Re: 929 cuts out at redline hard to start...help

thats easier said than done. now when i say it cuts out when it hits redline it is roughly in that range. its right at the peak of changing gears so it is not predictable...thats the problem i have. it is not normal... i dont like it and want to fix it. for example. if it is sitting on the side stand after it is warmed up and even then if i rev it up, high rpm i might add, it will cut out. my two buddies have the exact bikes, and it does not happen to theirs...i may try switching computers and see if i can duplicate it then...i just dunno...im frustrated.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome