Honda Motorcycles - FireBlades.org - Reply to Topic
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

Thread: Mille mirrors on a 954 blade Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-20-2016 9:29 PM
deltel
Re: Mille mirrors on a 954 blade

Yea I've had a few bikes since then gsxr1000,Vtec Vfr on a Tuono now must be gettin old 😂
Miss the blade tho was so comfortable even on long journeys
06-20-2016 9:18 PM
Defomx26
Re: Mille mirrors on a 954 blade

Came out awesome!
06-20-2016 7:43 AM
deltel
Re: Mille mirrors on a 954 blade

Yea They were Chinese copy's the bolts were slightly out but as I was drilling through the fairing and the frame to bolt it down it didn't matter
06-20-2016 4:23 AM
BenelliBlade
Re: Mille mirrors on a 954 blade

That looks great, really suits the 954. I guess the mirrors are from the later shape RSV (2004->)? Is the bolt spacing exactly the same?
06-19-2016 10:34 PM
deltel
Mille mirrors on a 954 blade

Did this mod a couple of years back put aprilia mille mirrors on my 954 thought id post it 👍feel free to post any questions pictures should be enough tho ☺️

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome