Honda Motorcycles - FireBlades.org - Reply to Topic
Honda FireBlade Discussion of the Honda CBR 900RR, Honda CBR 929RR, Honda CBR 954RR, and Honda CBR 1000RR Motorcycles.

Thread: 929 clutch not disengaging all the way Reply to Thread
Title:
Message:

Register Now



In order to be able to post messages on the Honda Motorcycles - FireBlades.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
A valid e-mail address is REQUIRED. You will not have access to any site features until you activate your account using the activation e-mail that is sent to this address.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-28-2008 6:20 PM
pnmox
Re: 929 clutch not disengaging all the way

Hi Did you find a solution to this problem?
I have had the exact same issue, even to the point of breaking the push rod due to not aligning before fitting the cover! Next step for me is to replace the steel drive plates, i am guessing they are warpped but didn't notice when the fibre plates were worn as the extra space was taken up by the warppage. Since fitting new fibre plates but with the old warpped steel plates the clutch has become too fat and when accuated there is not enough space for the fibre and steel plates to disenage. Make senese to me will let you know how i get on!
07-26-2008 5:32 PM
pavetim
Re: 929 clutch not disengaging all the way

at first i didn't have the cam lined up so when i tightend down the cover the corner of the cam snapped off so I replaced the cam. I'm pretty sure the cam and button are coupled together cause the clutch would not actuate at all if they weren't. Don't know have to pull it apart again and see if I see anything which I won't, this thing has me baffled. Seems as though everything is put together the right way.
07-26-2008 12:03 PM
bladeracer
Re: 929 clutch not disengaging all the way

The cam is the bottom of the rod that goes down into the cover and into the groove in the lifter.
As I said, I haven't had to pull mine apart but I don't think it matters if the lifter moves as long as it rests against the bearing in the inner hub.
When you put the cover on did you align the cam into the groove in the lifter rod?
I don't understand what you mean about breaking a corner off something either.
07-26-2008 8:29 AM
pavetim
Re: 929 clutch not disengaging all the way

The old clutches started to slip a little bit. But the cable was perfectly fine with the old ones though. I didn't take the basket. Whats is the clutch cam? The nipple that the clutch rod grooves into? Don't think it's damaged, but when you put the clutch together is it supposed to move in and out about a half inch? or when you take the front clutch cover off is the cam supposed to come out? Thats the only thing I can think of.
07-26-2008 1:30 AM
bladeracer
Re: 929 clutch not disengaging all the way

I haven't been into these clutches yet so I don't know if there's some common mistake with them.
About all I can think of is if the clutch basket nut is loose but you shouldn't have had to remove that to replace the clutch plates.
What was the old clutch doing that caused you to replace it?
Has it done this since you put the new clutch in or is it a new problem?
Did you thoroughly lube all the plates during assembly?
Was the clutch lifter damaged when you damaged the actuating rod?
07-25-2008 10:17 PM
pavetim
929 clutch not disengaging all the way

I replaced the clutch in my 2001 929RR. I acidentally didn't have the actuating rod set up right so I broke a corner off. I replaced it. But now the calbles at the lever and engine are maxed out and it drags still. the actuating rod is at a 90 degree angle to the engine. It seems as though it's not pulling the clutch enough. What else could this be? The clutch, the actuating rod, and cable are all brand new.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome