Honda Motorcycles - FireBlades.org

Honda Motorcycles - FireBlades.org (https://www.fireblades.org/forums/)
-   Honda FireBlade (https://www.fireblades.org/forums/honda-fireblade/)
-   -   Indicator Issues - Unknown Cause (https://www.fireblades.org/forums/honda-fireblade/114125-indicator-issues-unknown-cause.html)

stueh 06-02-2016 8:48 AM

Indicator Issues - Unknown Cause
 
Hi Everyone,

Late last year I purchased a borked '01 929. Some elbow grease and a little TLC and she was right as rain, but there's still got one problem I can't work out for the life of me.

When I use the indicator (left or right), it will take anything from a few seconds to a few minutes for the indicators to actually start flashing.

Initially, I thought it was the flasher cam, but replaced that and the issue persisted. Visual inspection of all four indicators, bulbs and bulb sockets show no issues, and a quick multimeter over the wires when the flashing actually happens shows full voltage.

I'm starting to think it's an issue with the switch housing. The bike was left outside unridden for some months before I purchased it, and hadn't been ridden for a good couple of years before that - housing etc. are rather sun-bleached, so I wouldn't be surprised if it was an issue.

Anyone have thoughts on it? I'm not keen on purchasing a new housing to replace the current one when I don't know for absolutely sure that it's the cause of the issue. Is it a common/known problem, or have you seen it before?

TIA :)

Catch22 06-02-2016 9:59 AM

Re: Indicator Issues - Unknown Cause
 
I'd find a long wire, both ends are showing bare wire. This is my ground tool. I now find a winker base, the winker having some metal base, anything metal on the winker is this wire end touching it. I turn the key on, winker blinking, I now ground the other wire end to a good known ground on the bike... are my winks running normal? Yes... wire a better ground from any winker to the frame... that or tear the whole bike down and assemble with clean, scraped to shinny bare metal finishes at their ground points... see what chemically happened leaving it outside? Rust [condensation] under the ground points and things pop up like poor winker grounds, etc. That's one guess at it.

unslow1 06-02-2016 11:30 AM

Re: Indicator Issues - Unknown Cause
 
I'd invest some time into CAREFULLY removing, disassembling, cleaning, reassembling, and reinstalling the control block. I had similar issues when I purchased my RR3, but after a thorough cleaning & lubricating, all is well :thumb:

Spaz 06-03-2016 4:01 AM

Re: Indicator Issues - Unknown Cause
 
Clean inside the control switch, it's dirty, that is all.


All times are GMT -4. The time now is 11:40 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2016 FireBlades.org. All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome