Honda Motorcycles - FireBlades.org banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
My FI light is blinking, it's one short and 5 long which is "15 Faulty no.4 fuel injector" I downloaded the service manual and it said step 1 turn the bike off pull the connector and check it for loose connections, everything looked good. Step 2 was to turn on the bike with the stand down and make sure MIL (FI Light) still blinks which its does.


The next steps were to start testing the resistance and for shorts in wiring or the injector, everything came back normal. Do you guys have any idea as to what could be causing this?


Resistance of Injector was 11.6 ohms (11.1-12.3 normal), it was bouncing in the high 20s then leveled out in at 11.6 and stayed there for 30 seconds. Is this a sign of a bad injector?

No Continuity at the Injector (good)

Injector Connector gave 12.8v (good)


Any ideas on what could be causing this???
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2 (Edited)
Background of the issue and previous trouble shooting done is below.

I rode my bike to the store and back the other day and didn't have any issues. I went to start it 3 days later and the battery appeared to be dead. I tried running it out and popping the clutch, it almost wanted to start a couple times but would jerk and smelled like straight gasoline dumped out the exhaust but it never started.

A couple days later I had my buddy jump my bike using cables with his bike and the bike started right up but as soon as I disconnected the cables it died. We did it one more time and left it connected and running for 5 min but it died again as soon as we disconnected it. This led me to believe it was a stator issue.

I bought a battery tender to try and charge my dead battery, which I later found out that it doesn't charge already dead batteries. So I pulled a battery from one of my buddies bikes that I'm storing in my garage and put it in. All my lights are coming on now, it's turning over but won't start.

Is it possible in the process of trying to pop the clutch or jump it off another bike that I caused a short in the wiring? I'm also confused as to why the battery would have just randomly died, it hasn't really been cold this winter so far and I had just ridden it a couple days before after it sat for almost a month and it fired right up.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
How would i check to see if it's getting gas? I checked the fuse on the starter relay and it was good.

It should have normal 12V running through the top two terminals when i turn the key on correct?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I tested the starter relay and got 12.7v. How can you test for fuel delivery?

Is the fault on the FI light preventing it from starting or is there another issue?
 

·
Registered
Joined
·
22 Posts
Is the fuel pump working? And if the bike has a fuel filter then try to see if gas is passing through the filter then you know it's getting fuel.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
I don't think it's the fuel pump, when I had my buddy over we jumped my bike from his and it ran fine for 5 minutes with the cables connected. Then once we took them off it would die so that's why i thought it was a battery issue. When I put a new battery in I was getting the FI code for Fuel Injector NO.4. I don't know how it could have possibly gone bad in the time of replacing it with a new battery, non of my fuses are blown either I've checked everything I could.

I want to try jumping the bike again and seeing if it will start again. It just seems so weird it was running so smooth then all of a sudden the battery appears to be dead so i jump it runs great but dies when disconnected. I put a good battery in and it won't start, I'm at a loss here....
 
1 - 9 of 9 Posts
Top