Honda Motorcycles - FireBlades.org banner

1 - 3 of 3 Posts

·
Registered
2002 Honda CBR 954rr
Joined
·
5 Posts
Discussion Starter #1
So to start off, I was riding my 02 954rr and all of a sudden my engine just cuts off on the interstate, electronics still on. Then I finally get pull off to the side of the road and try to start the bike but no luck, its cranking just not starting. From then on I checked my fuses cause it was the easiest at the time, then checked my kickstand solenoid to make sure.... but the bike wouldn't even start in neutral. I started to think of what it could be then 10 mins went past and the bike started right up, i put my gear back on and proceed to get back home and the problem happened again. I didn't try to start it again after that because the next exit isn't really that friendly at night.

I basically need answers as to what you guys must think this might be.
I have not done any tests yet to see what it might be (just too busy).

Could it be the rectifier?

also something else to note, ive had a similar instance like this where after a long ride i would fill the bike with gas and try to start the bike back up and it wouldnt start so i would have to wait a couple minutes before itd want to start again.

Yes the fuel pump primes and Yes I had plenty of gas.
 

·
Registered
Joined
·
1,543 Posts
take a look at this thing - orange connector in the loom. RH side. The pins corrode then when they get hot they don't make proper connection and the bike wont run. The black/white wires re the ones feeding 12v to the coils and injectors. I spent months chasing this on my 929!

IMG_3594.JPG IMG_3597.JPG
 

·
Registered
2002 Honda CBR 954rr
Joined
·
5 Posts
Discussion Starter #3
1 - 3 of 3 Posts
Top