Honda Motorcycles - FireBlades.org banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I recently bought this bike, drove it about 500 miles fine, then moved to ATL, was a 300 mile trip, but last 50 the bike acted bogged down. Took it to a shop when I finally got here to get diagnosed. They said fuel pump was fried possibly because of wiring issues. It was too much for them to fix, so I took it home, it died on me on the way home, and I ended up pushing it about 2 miles home. Luckily I live close to the shop.

I replaced the fuel pump, but now I can't even get the headlights, bright indicator, or brakes to come on when i turn the key, and I can't check to see if the the fuel pump I installed is working.
Am I looking at replacing the main wiring harness now? The guages come on, except for brights. All fuses are good. Any ideas?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I swapped the two with each other and didn't get anything different. But doesn't mean That both could bad. I don't use the starter relay, as I have a toggle switch that goes directly to the solenoid.

You are talking about the two undermearth the rear fairing right?
 

·
Registered
Joined
·
21 Posts
The f4i seems to be slightly different than my 919 with regard to number of relays, on mine the engine stop relay was preventing other relays from getting power to turn on the devices they were attached to and there were separate relays for blinkers and taillights. Here is a wiring diagram for the f4i http://www.bluegauges.com/images/reference/wiringdiagrams/f4i.jpg
it gives me a headache just to look at that, so bust out the multimeter and good luck, haha. :patriot:
 
1 - 4 of 4 Posts
Top