Honda Motorcycles - FireBlades.org banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I just got a used '95 SC28 CBR900 and I am trying to figure out when the radiator fan is supposed to start working. The bike does not have a digital temperature meter. It has an analog gauge with a red zone at the end.

I saw the needle going all the way just before touching the red zone but the radiator fan never kicked in. Is that normal or do i have a temperature sensor problem ?
 

·
Registered
Joined
·
213 Posts
sounds like the fan switch/or the fan it self has failed, also check the fuse, the switch is the part that screws into the radiator, make sure its all connected up ok. To check the fan, disconnect the wire from the switch to the left of the rad, turn on the ignition, and earth the switch wire, as the wire is earthed the fan should come on, then you know the fan is ok, and you just need a new fan switch, if the fan dont come on you need a new fan.
 

·
Super Moderator
Joined
·
32,034 Posts
Hello, I just got a used '95 SC28 CBR900 and I am trying to figure out when the radiator fan is supposed to start working. The bike does not have a digital temperature meter. It has an analog gauge with a red zone at the end.

I saw the needle going all the way just before touching the red zone but the radiator fan never kicked in. Is that normal or do i have a temperature sensor problem ?
The fan would come in just after boiling point so around 102C I'd guess.
My ZX6R has an eight-block LCD gauge. It normally runs in the third block and the fan comes on at the fifth block. I'd guess the halfway mark is around the 100C mark.
Try connecting power directly to the fan and see if it works. If it does then look at the wiring and the fan switch.
 
1 - 5 of 5 Posts
Top