Honda Motorcycles - FireBlades.org banner

1 - 4 of 4 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
Just put my CBR929 back together after an engine refresh which included a 2mm overbore and new Weisco 13.5:1 pistons.

I am planning to take it to get a custom dyno tune but only after it starts and runs so I know all they will need to do is tune it and anything else is sorted out.
Should it start and run on the 929rr tune that I had previously which matched the exhaust?

Right now it starts and fumbles but won't stay running. I'm wondering if its because of the added displacement on the 929 tune or if I have my TP sensor messed up.
 

·
Registered
Joined
·
717 Posts
Just put my CBR929 back together after an engine refresh which included a 2mm overbore and new Weisco 13.5:1 pistons.

I am planning to take it to get a custom dyno tune but only after it starts and runs so I know all they will need to do is tune it and anything else is sorted out.
Should it start and run on the 929rr tune that I had previously which matched the exhaust?

Right now it starts and fumbles but won't stay running. I'm wondering if its because of the added displacement on the 929 tune or if I have my TP sensor messed up.
I'm not sure why lots of people think the piston are manufactured by Weisco not Wiseco. I can send you map in few days when i get it uploaded from my pc3 to computer. Have you tried to raise the idle from the screw. Mine needed to get the flaps opened up a lot before it started the first time.
 
1 - 4 of 4 Posts
Top