Honda Motorcycles - FireBlades.org banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,

Joined here years back then lost login details so rejoined. I need advice from the great & good please! :)

I have mint 2000 929 which has been faultless so far. However, i recently stalled it on a cold morning on my gravel drive. Pressing the starter restarted the bike but killed the digital dash and rev counter. The backlight and warning lights still work.

All functions returned briefly later in the day, then disappeared again.

I have checked fuses,connections etc. All fine. I note that if I disconnect and reconnect the battery, the dash returns,until i start the bike, then they disappear again.:idunno:

any thoughts? Like i say, the dash can be made to work, so the lcd is not dead.

really welcome any insight. Thanks,

Chris
 

·
Registered
Joined
·
12 Posts
Did you try and disconnect the cluster from the connector on the back of the unit and reconnect it? It's possible that there is a loose connection and is getting poor connection from the vibrations.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hi,

Yes, I went through all the connections, removed the dash etc. What I have subsequently found is that if I disconnect the battery and reconnect, the dash worked until I start the bike, then the dash disappears again.

My thoughts therefore, - must be battery. I've had the battery on charge for a few days. All seems fine now. I will take it out this weekend and give it a run to test (with a few starts/stops/restarts) to ensure it seems robust.

It would tie in with the idea that when I stalled on my driveway and restarted, the battery was low and the bike started but somehow the power is not sufficient to drive the dash. Odd, but looking like the case.

Thanks for your reply.:)
 
1 - 3 of 3 Posts
Top