Honda Motorcycles - FireBlades.org banner

1 - 11 of 11 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
Hi there
just got a 929 running again after about 4 years. New ECU, fuel pump, all major service stuff. Starts and ticks over well but when riding lacks power and sounds as if it's only firing on 3. Suspect a duff coil. Any thoughts?
Thanks
 

·
Super Moderator
Joined
·
32,034 Posts
Hi there
just got a 929 running again after about 4 years. New ECU, fuel pump, all major service stuff. Starts and ticks over well but when riding lacks power and sounds as if it's only firing on 3. Suspect a duff coil. Any thoughts?
Thanks

Fuel pressure regulator perhaps.
 

·
Registered
Joined
·
993 Posts
You can find out which cylinder after the bike is running (not even a minute) and feel the headers the second you start the bike... keep touching each one until you notice one that is staying colder than the others (that's the one not running obviously).

Then you can shut the bike off and try to isolate why that cylinder isn't running... think Air, Spark, Fuel:thumb:

GL!
 

·
Registered
Joined
·
6 Posts
kinda sounds like my 929. It starts right up but it takes couple seconds for the last cylender to kick in. i put new plugs and k & n air filter on it. ran great until last nite it was boggy and really choppy. But if i take it out a get on it it runs better. dont no whats going on. It runs rich to.
 

·
Super Moderator
Joined
·
32,034 Posts
kinda sounds like my 929. It starts right up but it takes couple seconds for the last cylender to kick in. i put new plugs and k & n air filter on it. ran great until last nite it was boggy and really choppy. But if i take it out a get on it it runs better. dont no whats going on. It runs rich to.

But you've already checked the fuel pressure regulator?
 

·
Registered
Joined
·
316 Posts
Check th fuel pressure regulator like bladeracer says. Mine went bad not too long ago an it caused a rough an rich idle but once I got riding it wasn't noticeable.

How can u tell th last cylinder isn't firing from th get go?
 

·
Registered
Joined
·
6 Posts
Sorry i have been really busy. But I was able to work on my bike. I checked the fuel pressure regulator and when i pulled the vacumm hose off the regulator fuel came out. Im guessing its bad. Im smelling alot of gas when the bike is running.
 

·
Super Moderator
Joined
·
32,034 Posts
Sorry i have been really busy. But I was able to work on my bike. I checked the fuel pressure regulator and when i pulled the vacumm hose off the regulator fuel came out. Im guessing its bad. Im smelling alot of gas when the bike is running.

Yep, you need a new FPR.
 
1 - 11 of 11 Posts
Top