Honda Motorcycles - FireBlades.org banner
1 - 20 of 33 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter · #1 ·
hey guys i have a 2000 cbr929rr. ive noticed that in low rpm cruising i get surges and rough running from idle to 3000 rpms. but right as soon as i hit 3000 rpms its like a huge power band kicks in. ive checked my flap in my airbox and its operating right. also when you first start it up and its ideling and you rev it up it puffs black smoke i know this black smoke is fuel related meaning its running rich im just wondering if this is also causing my surging. i was wanting to know if anyone else has this problem or has had it and fixed it and what it might be. ive heard that these bike have low rpm roughness but if i gas my bike hard under 3000 rpms it almost cuts out and dies. i want to get this fixed it bugs the hell out of me. oh and also im not throwing any error codes. thanks for the help in advance
 

·
Premium Member
Joined
·
32,034 Posts
hey guys i have a 2000 cbr929rr. ive noticed that in low rpm cruising i get surges and rough running from idle to 3000 rpms. but right as soon as i hit 3000 rpms its like a huge power band kicks in. ive checked my flap in my airbox and its operating right. also when you first start it up and its ideling and you rev it up it puffs black smoke i know this black smoke is fuel related meaning its running rich im just wondering if this is also causing my surging. i was wanting to know if anyone else has this problem or has had it and fixed it and what it might be. ive heard that these bike have low rpm roughness but if i gas my bike hard under 3000 rpms it almost cuts out and dies. i want to get this fixed it bugs the hell out of me. oh and also im not throwing any error codes. thanks for the help in advance

Have you checked the fuel pressure regulator?
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #3 ·
Yes its not leaking gas out of the vacuum line and it looks really clean.its not all gunked up. I dont know if theres another way to check it or not?
 

·
Premium Member
Joined
·
32,034 Posts
Yes its not leaking gas out of the vacuum line and it looks really clean.its not all gunked up. I dont know if theres another way to check it or not?

Torn diaphram is the major concern so it sounds fine.
You can also run a fuel pressure test if you have the equipment.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #5 ·
I dont have the proper equiptment to run a fuel pressure test. I just got in to fuel injection all my tools were for carb bikes. I dont think its the diaphram in the fuel regulater. I would think if it was it would let gas into my vacuum lines.
 

·
Premium Member
Joined
·
32,034 Posts
I dont have the proper equiptment to run a fuel pressure test. I just got in to fuel injection all my tools were for carb bikes. I dont think its the diaphram in the fuel regulater. I would think if it was it would let gas into my vacuum lines.

Yep, that's what it does when it fails.
Another thing it could be is the fuel filter so you may want to replace that.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #7 ·
It could be that it sat for a while i think it hasnt been registered in 2 years. But its weird though when you hit 3000 rpm's its like a powerband on a 2 stroke lol. Its just real choppy under 3000 rpm's. I would think if it was a fuel filter it would run like poop through the whole rpm range. It seems like its running rich. Sometimes when i rev it up it blows black smoke which means its running rich. Im wondering if that has something to do with it. Also do the 929's have O2 sensors? The manual says it does but mine doesnt. I thought it was the 954 with the O2 sensor's. The only mod i have is a akropovic bolt on. The air box flapper is working and set properley also.
 

·
Premium Member
Joined
·
32,034 Posts
It could be that it sat for a while i think it hasnt been registered in 2 years. But its weird though when you hit 3000 rpm's its like a powerband on a 2 stroke lol. Its just real choppy under 3000 rpm's. I would think if it was a fuel filter it would run like poop through the whole rpm range. It seems like its running rich. Sometimes when i rev it up it blows black smoke which means its running rich. Im wondering if that has something to do with it. Also do the 929's have O2 sensors? The manual says it does but mine doesnt. I thought it was the 954 with the O2 sensor's. The only mod i have is a akropovic bolt on. The air box flapper is working and set properley also.

The engine isn't designed to pull throttle below around 4000rpm so it's fairly useless trying to make it operate that low in my opinion.
It makes black smoke when you rev it how high?
What matters is if it smokes under load while you're riding, rather than no load while stationary.
Neither has an O2 sensor except in some specific markets in Europe and California.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #9 ·
Hmmm didnt know that aboput the O2 sensor on the 954. I dont notice it under a load as my head is forward watching the road lol. I dont know what to do haha i just want to ride and have my bike at 100%. I just dont like how its jumpy and jerky when it wats to be under 3000. Im not try to romp on it under 3000 i just cruise at about 2500-3000 and if im right at 3000rpm's its cutting in and out and it really pisses me off
 

·
Premium Member
Joined
·
32,034 Posts
Hmmm didnt know that aboput the O2 sensor on the 954. I dont notice it under a load as my head is forward watching the road lol. I dont know what to do haha i just want to ride and have my bike at 100%. I just dont like how its jumpy and jerky when it wats to be under 3000. Im not try to romp on it under 3000 i just cruise at about 2500-3000 and if im right at 3000rpm's its cutting in and out and it really pisses me off
You shouldn't be cruising that low. The revs should rarely be under 4000rpm. That's what you have six gears for, to keep the revs up to where they need to be.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #11 ·
I rarely do have it that low i usually cruise at 4500 or 5000 rpm's i just dont like taking off from a stop and feel like im riding a mechanical bull lol
 

·
Premium Member
Joined
·
32,034 Posts
I rarely do have it that low i usually cruise at 4500 or 5000 rpm's i just dont like taking off from a stop and feel like im riding a mechanical bull lol
I wouldn't be that low even when taking off.
If I'm moving at walking pace I just pop the clutch to get moving and then pull it in again and coast until I need more speed - or better still, find another route :)
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #13 ·
U take off from a stop higher than 5000 rpm's? Im surprised u still have a clutch. I would understand maybe if you were at a drag srip but not on the streets
 

·
Premium Member
Joined
·
32,034 Posts
U take off from a stop higher than 5000 rpm's? Im surprised u still have a clutch. I would understand maybe if you were at a drag srip but not on the streets
You only need 4000rpm and no, it's nothing like a hard launch. On the racetrack I launch around 7000rpm.
 

·
Premium Member
Joined
·
32,034 Posts
Remember that 4000rpm in first with stock gearing is only around 45kph or 27mph.
With my 15/47 gearing it's around 38kph or 23mph.
It really is not a hard or fast launch.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #17 ·
it never back fires. its just really rich...... after it warms up it goes away. when a motor warms up it leans its self out a bit. if i start my bike after its cooled all the way down and blip the throttle it cuts out and stutters like its a carb'd bike that hasnt warmed up yet. im wondering if the injectors are crap. even though the bike hasnt fully warmed up to operating temp it should still run half descent when first started. its not cold here so its not the weather. it 90+ degrees with like 80-90% humidity it sucks balls. i ran some sea foam through it really didnt change anything. i dont know what the hell this bikes deal is, i guess it cause its a honda ;)
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #19 ·
i dont want to get on the throttle. if im moving it around and i rev it a bit to raise rpm's it cuts in and out a bit. im not gonna hop on my bike right as soon as i start it and try o do 200mph. i dont need to get on the throttle as soon as i start it temperedDICK. lol jk timmy :eyebrows:
 
1 - 20 of 33 Posts
Top