Honda Motorcycles - FireBlades.org banner
1 - 20 of 44 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
Just got the bike and I notice it stutters slightly on low power take offs. I usually rev to around 4k and slowly clutch out. Any lower then 4k and the bike seems to want to stutter heavily on take off. And when I mean slowly clutch out, it seems I have to go way slower then I should to not have the bike stutter. The bike is a 00' 929rr, it has a full erion racing exhaust but no power commander. I was curious if the racing exhaust is making it run too lean, and maybe a power commander would fix this behavior.

Also, side question, if I were to get a PC3, are they model/brand dependent like some access ports are for vehicles? I see some on ebay but they list the specific model or brand.
 

·
Registered
Joined
·
116 Posts
mine dose that on takeoff when I have been riding it in the rain for ten+ minutes. I think its because the air filter gets wet and reduces air flow to the motor. I have a gutted air box so thats probably what dose it. not that i should be riding in the rain anyway but i do. never had any shutter aside from when it was raining. although if I where you I would check and see what the condition of the air filter is. if its old and clogged up then that could be causing your trouble perhaps.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #3 ·
Well either there is something the injectors need cleaning, old gas since I bought it used from the dealer, same tank for quite awhile, or nothing is wrong and the full exhaust needs a map to behave. So something is either wrong, or I need a PC is what it comes down to? -.-
 

·
Premium Member
Joined
·
32,104 Posts
Well either there is something the injectors need cleaning, old gas since I bought it used from the dealer, same tank for quite awhile, or nothing is wrong and the full exhaust needs a map to behave. So something is either wrong, or I need a PC is what it comes down to? -.-
Or ride another one and see if it's the same?
 

·
Registered
Joined
·
824 Posts
put a little lucas injector cleaner in on your next tank, DEF check the air filter. It could very well be the fueling...Full exhausts should ALWAYS be ran with fuel management...the engine gets rid of air a lot faster with a full exhaust..especially on the older bikes because the headers werent designed all that great...so you have all that new air going in but no extra fuel to compensate...I dont think it is the injectors or air filter though because you would see problems in all the rpm ranges and not just down low ...but its better to check the easy stuff first..the more i think about it the more i think it could be the fueling...the reason why it is happening down low is because that is where the least amount of fuel is dumped into the engine...it could very well be lean everywhere else too but your just not noticing because its not bad enough to cause hesitation...Either way..even if it isnt the fueling you should still have a PC3 so that your engine doesnt get ruined from lean running conditions...and yes the PC is year/model specific...some work for a couple years but they usually change every 2-3 years when the bike changes...i believe the 929 and 954 can run the same PC3...but i could be wrong...it all comes down to connectors....any PC would work on any bike pretty much its just a matter of the connectors not fitting right but if you were really good with electronics like my buddy is you could taylor any PC to work...but its not worth it?!?! just go get the right one...new..not used...and be happy with the nice power it should give you...that full exhaust is probably ROBBING power from your bike without the PC...
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #7 ·
Awesome advice! I <3 you.
put a little lucas injector cleaner in on your next tank, DEF check the air filter. It could very well be the fueling...Full exhausts should ALWAYS be ran with fuel management...the engine gets rid of air a lot faster with a full exhaust..especially on the older bikes because the headers werent designed all that great...so you have all that new air going in but no extra fuel to compensate...I dont think it is the injectors or air filter though because you would see problems in all the rpm ranges and not just down low ...but its better to check the easy stuff first..the more i think about it the more i think it could be the fueling...the reason why it is happening down low is because that is where the least amount of fuel is dumped into the engine...it could very well be lean everywhere else too but your just not noticing because its not bad enough to cause hesitation...Either way..even if it isnt the fueling you should still have a PC3 so that your engine doesnt get ruined from lean running conditions...and yes the PC is year/model specific...some work for a couple years but they usually change every 2-3 years when the bike changes...i believe the 929 and 954 can run the same PC3...but i could be wrong...it all comes down to connectors....any PC would work on any bike pretty much its just a matter of the connectors not fitting right but if you were really good with electronics like my buddy is you could taylor any PC to work...but its not worth it?!?! just go get the right one...new..not used...and be happy with the nice power it should give you...that full exhaust is probably ROBBING power from your bike without the PC...
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #10 · (Edited)
There is some dispute at the dealer, but some think its actually a slip on erion, so yea... dealer lied to me! But um, I had an ECU management installed, not a PC though, its from dobeck, feels great. I ran through the tank, added 91 oct fuel, and injector cleaner. Works like a charm and I love it to bits.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #12 ·
Yes, the 929 has factory "Titanium" headers and an HTEV.
I read up on it, and from what I can tell....I have no idea if its a good or bad thing :idunno:.

I think I may go back to the dealer to have them dick around with the EFI a smidge more, they dialed in the mid range, but low range seems off from my butt dyno.

I got another question for yall...

When you are cruising around in city streets, easy take offs from stop, what RPM do you generally rev to.
 

·
Registered
Joined
·
824 Posts
what kind of valve does it have...like a exup valve? or like a blow off valve? never had a 929 so im curious...does that 954 have it too? if you add a slip on does it emilinate it or is the valve part of the headers?
 

·
Premium Member
Joined
·
32,104 Posts
what kind of valve does it have...like a exup valve? or like a blow off valve? never had a 929 so im curious...does that 954 have it too? if you add a slip on does it emilinate it or is the valve part of the headers?
HTEV is a rotary valve just before the collector.
 

Attachments

·
Premium Member
Joined
·
32,104 Posts
Too bad you are running a cbr1000, I read about the 00-01' 929s, they stutter under 3k, only complaint reviewers had. I find myself having to rev to 3-4k for take offs.
All of my bikes (including the 929 with full Akrapovic) will launch with no throttle input, but it's not something I'd bother with unless I had a broken throttle cable maybe.
4000+ is much more useful.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #19 ·
All of my bikes (including the 929 with full Akrapovic) will launch with no throttle input, but it's not something I'd bother with unless I had a broken throttle cable maybe.
4000+ is much more useful.
hmmm, think something is wrong still with my bike? I engadge the clutch at 3k from a dead stop, anything less and the bike stutters...I could never launch with no throttle input.
 

·
Registered
Joined
·
11,722 Posts
what kind of valve does it have...like a exup valve? or like a blow off valve? never had a 929 so im curious...does that 954 have it too? if you add a slip on does it emilinate it or is the valve part of the headers?
its the same thing as the valve in your exhaust, just in a different spot in the exhaust system.

hmmm, think something is wrong still with my bike? I engadge the clutch at 3k from a dead stop, anything less and the bike stutters...I could never launch with no throttle input.

yes something is wrong with your bike. I've had two 929s with a couple different bolt on cans and currently a full exhaust system. neither bike ever needed to be reved to take off. slowly letting the clutch out and the bike starts to move. I never really rev my bike any when taking off, maybe a couple hundred rpm at most. I do it pretty much just like I would in a car, balance the clutch and gas and go.
 
1 - 20 of 44 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top