Honda Motorcycles - FireBlades.org banner

1 - 4 of 4 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
My bike lags through out the gears when I'm light on the throttle, trying to maintain the same speed at about 5k rpm and lower. Then when I give it a little more throttle it jumps and runs normal. I have a bmc air intake, full arata exhaust system, the O2 sensor is just hanging out underneath the seat, and I have a pc3 installed that is mapped for a full yoshi system with intake (there was no map for the arata system I have). I just purchased this 929 and its the third one I've owned. None of the previous ones had this issue... even the first with full yoshi pc3 and no O2 sensor. Is the pc3 map causing this? The issue is still present even when I run no map. My bike is getting about 25 mpg... the other two would get at least 35 mpg with the same riding style and they were regeared -1 front +2 rear.

 

·
Premium Member
Joined
·
32,034 Posts
My bike lags through out the gears when I'm light on the throttle, trying to maintain the same speed at about 5k rpm and lower. Then when I give it a little more throttle it jumps and runs normal. I have a bmc air intake, full arata exhaust system, the O2 sensor is just hanging out underneath the seat, and I have a pc3 installed that is mapped for a full yoshi system with intake (there was no map for the arata system I have). I just purchased this 929 and its the third one I've owned. None of the previous ones had this issue... even the first with full yoshi pc3 and no O2 sensor. Is the pc3 map causing this? The issue is still present even when I run no map. My bike is getting about 25 mpg... the other two would get at least 35 mpg with the same riding style and they were regeared -1 front +2 rear.


Have you checked the fuel pressure regulator?
Does it have an O2 sensor eliminator for the PC3?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Yeah.. the fuel on the pc3 was too high and the stock settings map was loaded. I put the low, mid, and high fuel settings on zero and loaded the zero map and the bike runs a lot better but still doesn't feel like it's running at it's best. I guess I just need to get the pc3 professionally tuned. :/

Thanks for the help :)
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
My problem is gone now. I ended up changing the spark plugs and lengthening the o2 sensor wiring and making an adapter to fit the o2 sensor in the exhaust. It was running so rich and crappy because of the o2 sensor not being plugged in.
 
1 - 4 of 4 Posts
Top