Honda Motorcycles - FireBlades.org banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I am exhausted with this bike. I diagnosed everything I could myself and then took my bike to the honda dealership. They can't figure out whats wrong and its been 2 months.

I took it out in the spring and tried to start. Fuel pump primes and no codes show but when i try to start it just cranks. Not even a pop or sputter. digging in i found no spark and no fuel from the injectors. I'm all out of ideas. I checked the main harness ground block myself. The shop found a wire with no continuity but after fixing that wire they still couldn't get it to start. I feel like the ecm would cause no spark but would it cause no fuel from injectors?

I'm at the point now where I'm considering parting the bike or swapping harness/ecm.

Any thoughts?
 

·
Registered
Joined
·
270 Posts
:welcome: to the forum.

The ecm would also cut the fuel as it controls how long the injectors remain open for. Do you know anyone else with a 929 where u could swap the ecm?

Hopefully Bladereacer will be along shortly with some advise for you
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
The shop swapped an ecu off a wrecked bike but they don't know if that one worked to begin with.
 

·
Registered
Joined
·
270 Posts
Not to much help, but if it was wrecked got to think it was ok which would point to yous being a wiring issue. Is yours definately a US model without HISS?
 

·
Registered
Joined
·
900 Posts
I take it you have checked the tilt switch, that is designed to cut off the fuel and stop the plugs sparking when you lay the bike down.
 

·
Registered
Joined
·
434 Posts
I am exhausted with this bike. I diagnosed everything I could myself and then took my bike to the honda dealership. They can't figure out whats wrong and its been 2 months.

I took it out in the spring and tried to start. Fuel pump primes and no codes show but when i try to start it just cranks. Not even a pop or sputter. digging in i found no spark and no fuel from the injectors. I'm all out of ideas. I checked the main harness ground block myself. The shop found a wire with no continuity but after fixing that wire they still couldn't get it to start. I feel like the ecm would cause no spark but would it cause no fuel from injectors?

I'm at the point now where I'm considering parting the bike or swapping harness/ecm.

Any thoughts?
Just a thought but have you checked out the emergency kill switch on the right clip on. I know it can fail and cause some real headaches. A lot of times it gets over looked.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
My bike is definitely a US model without HISS. I don't think it's the tilt switch as it cuts the fuel pump and the pump primes fine? If I'm not mistaken the emergency kill switch kills the pump too?
 

·
Registered
Joined
·
262 Posts
I was messing with mine the other day tying to start it with the tank up and the seat bracket off. The one where the tilt sensor is located. The pump came on but no fire. Then i looked down and my tilt switch washanging by its own wires. Sat it back up where its supposed to go and BAM fired right up. Just saying check your sensor it might be bad it wouldnt hurt youve already had it to the honda dealer 2 times they cant figure it out so make them feel dumb and figure it out by yourself lol.
 

·
Registered
Joined
·
13 Posts
My 93 is not FI but when my engine run/stop switch is in the stop position the starter still turns over but the fuel and spark is killed. Might be an issue with your switch. Just a thought and good luck.
 
1 - 10 of 10 Posts
Top