Honda Motorcycles - FireBlades.org banner

1 - 20 of 26 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
hi all, i must have read every thread on here and couldnt find what i was looking for. i recently bought a 929rr that was crashed, well when i say crashed it literally fell over, any way i bought it off a bike shop who replaced the engine because of a cracked engine casing. i bought it before they finished it. the issue i have is the fuel pump will not prime, ive replaced all relays fuel cut engine stop etc i have tested the bas and is fine, ive tested the zener diode its ok, i hard wired the fuel pump and got it to run, it ran for like five seconds and stopped, since then no joy. the wierd thing is that when i put the fuel tank back in position it blows fuses, ive pulled the wiring and checked for shorts but now am at a loss doeas anyone hve any ideas, regards and thanks very many patrick
 

·
Premium Member
Joined
·
32,034 Posts
hi all, i must have read every thread on here and couldnt find what i was looking for. i recently bought a 929rr that was crashed, well when i say crashed it literally fell over, any way i bought it off a bike shop who replaced the engine because of a cracked engine casing. i bought it before they finished it. the issue i have is the fuel pump will not prime, ive replaced all relays fuel cut engine stop etc i have tested the bas and is fine, ive tested the zener diode its ok, i hard wired the fuel pump and got it to run, it ran for like five seconds and stopped, since then no joy. the wierd thing is that when i put the fuel tank back in position it blows fuses, ive pulled the wiring and checked for shorts but now am at a loss doeas anyone hve any ideas, regards and thanks very many patrick

Is the HISS working?
 

·
Premium Member
Joined
·
32,034 Posts

·
Registered
Joined
·
10 Posts
Bad ground on the earth at the back of the frame (just in front of the shock) will cause the fuel pump not to prime.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
Took out and stripped the loom today cleaned all connectors and earth nothing seemed out of the ordinary. It will now run wen I hardwire the pump but wont prime other wise
 

·
Premium Member
Joined
·
32,034 Posts
Took out and stripped the loom today cleaned all connectors and earth nothing seemed out of the ordinary. It will now run wen I hardwire the pump but wont prime other wise

Is there power at the fuel pump relay?
 

·
Premium Member
Joined
·
32,034 Posts
There is indeed

Then I can only guess that something is telling the ECU not to run the pump.
Did you check the ground junction block in the harness is good?
And the MIL is no longer on?
 

·
Premium Member
Joined
·
32,034 Posts
Yeah was thinking that but what. Mil light is on and the fault is map sensor but thats all good

HISS perhaps?
Can you borrow another ECU and key to try?
Pulse generator and cam sensor but you'd usually get a MIL if they're not working. Also the injector harness which you did say was throwing a MIL.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #14
Its not the hiss i reckon as it's only after getting a new key coded to it. Injector loom was redone this morning. Wat I dont get is why the tank sparks and blows the dash fuse wen the tank touches the frame
 

·
Premium Member
Joined
·
32,034 Posts
Its not the hiss i reckon as it's only after getting a new key coded to it. Injector loom was redone this morning. Wat I dont get is why the tank sparks and blows the dash fuse wen the tank touches the frame

What do you mean by "it's only after getting a new key coded to it"?
Has the bike been running at all with the current key?
I've heard of the tank shorting problem but I don't know what causes it, I would assume the power feed to the pump is somehow shorting to the tank - but I'm only guessing there.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #16
The key was lost so I got a new key coded for it. The bike does run wen the pump is wired to an external power source
 

·
Premium Member
Joined
·
32,034 Posts
The key was lost so I got a new key coded for it. The bike does run wen the pump is wired to an external power source

How did you get a key added to the ECU if you didn't have the original key?
It can be done I guess, just haven't seen it.
You may have a point, I'd have to check whether the HISS cuts spark as well as fuel.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
I dunno how he did it but was done before I bought the bike. He cut open the ecu did witch craft now it works. Not sure if hiss cuts fuel or spark or both
 

·
Premium Member
Joined
·
32,034 Posts
I dunno how he did it but was done before I bought the bike. He cut open the ecu did witch craft now it works. Not sure if hiss cuts fuel or spark or both

When you say "now it works" you mean that he did actually have the bike running?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #20
No I bought the bike before the shop finished it. Afaik he put a new chip in ecu and coded key to it. The hiss light goes out and all relays turn on and off as they should
 
1 - 20 of 26 Posts
Top