Honda Motorcycles - FireBlades.org banner

1 - 7 of 7 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
Hey All

Weird thing has started, switch on ignition, click on kill switch, nothing no fuel pump, couple of times, then it comes right, then the fuel pump sounds different, as if it drags a bit, (drags e.g the normal sound but slower) crazy, i know.

Sometimes, i switch the ignition on and kill switch, leave them both on for about 15 seconds, and the fuel pump automatically kicks in?

fuel pump relay / kill switch fault?

fuel pump noise due to it not starting and to much pressure in the line?

advice please guys.

H:eek:
 

·
Registered
Joined
·
547 Posts
Hey All

Weird thing has started, switch on ignition, click on kill switch, nothing no fuel pump, couple of times, then it comes right, then the fuel pump sounds different, as if it drags a bit, (drags e.g the normal sound but slower) crazy, i know.

Sometimes, i switch the ignition on and kill switch, leave them both on for about 15 seconds, and the fuel pump automatically kicks in?

fuel pump relay / kill switch fault?

fuel pump noise due to it not starting and to much pressure in the line?

advice please guys.

H:eek:
BATTERY CHECKED?
 

·
Registered
Joined
·
900 Posts
sounds like a bad connection, check them all, try some wd40, if know joy there, turn all on when it does kick in check temp on relay, if its sticking it will be warm....
 

·
Registered
Joined
·
180 Posts
Discussion Starter #4
Thanks guy's .

New battery , approx 6 months, will check it anyways, also will check the connections, any ideas to the dragging noise on the fuel pump?

H
 

·
Registered
Joined
·
900 Posts
if its not getting enough juice it will drag, if there is enough juice then the primer could be on the way out...rare though.......
 

·
Registered
Joined
·
7,366 Posts
Pull the switch gear apart and have a look at the kill switch - they can at times play up (worth pulling apart)
 
1 - 7 of 7 Posts
Top