Honda Motorcycles - FireBlades.org banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I purchased a 954RR a couple months ago and it has a full Two Brothers exhaust and PC IIIR. It rode fine for the first month, but then started having problems when I was cruising down the road at partial throttle. Now it is to the point where it will pretty violently stutter at partial throttle and even occasionally die.

When cruising down the road, the tach needle will drop to 0 and then jump back to ~4k (depending on how fast and what gear, obviously), do this a few times and the MIL and FI light will come on, but if I give it more throttle, it will smooth out and the lights will turn off, but if I leave it at part throttle or pull the clutch, it will die. If it dies, I can instantly start it back up and it will then run fine for a little bit.

I checked the FPR by taking the vacuum line off and pressurizing the system and no fuel dripped out. I changed the spark plugs and even disconnected the PC and it still has the same problems.

I will use a jumper wire and check the MIL for codes when I get home today, but I'm not sure if any codes are stored because the light only stays on when it is stuttering, otherwise it will turn off.

Any ideas? Thanks in advance!
 

·
Registered
Joined
·
94 Posts
Check your battery connections first off I have had the same signs before and it was a loose battery connection. Just a guess and is very easy to check!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Checked the battery, the positive terminal was loose. Tightened it up, took it for a spin and it ran great! Thanks jqcbr954 for the suggestion, I seem to always overlook the simple stuff.
 
1 - 5 of 5 Posts
Top