Honda Motorcycles - FireBlades.org banner

1 - 15 of 15 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter #1
My fireblade has never given me any issues first off. I parked it this fall in my heated shop. Had a tender on it, started it a couple times. Then one day I go to start it and nothing, turns out my tender died and my battery as well. Fast foward to now and i buy a new battery and install. The bike cranks fine, no warning light, but the fuel pump will not prime. The relay in front of the battery does click when i turn the key on. The bike has hit a few times but wont run, so i know the ignition is working. Just not the fuel pump. Fuse is good as well.

Any suggestions on what to check next?

Thanks
 

·
Registered
Joined
·
247 Posts
Discussion Starter #2
So the relay for the fuel pump kicks on for 5-10 seconds with the key on, then turns off. OR at least some relay does. but not the pump. unpluged the pump and went to the 3 wires and when i turn the key on i get 10.5v across one green and one brown. Locked up fuel pump?
 

·
Heeza Y Zasch
Joined
·
3,033 Posts
Check the ENGINE STOP RELAY in the tailsection. You may be able to access it through the "passenger" seat.
 

Attachments

·
Heeza Y Zasch
Joined
·
3,033 Posts
no. I must've been off my meds :bonk:

please excuse me. :O check any/all connections. clean. lubricate. if still no joy, try applying 12v direct.
 

·
Premium Member
Joined
·
2,615 Posts
So the relay for the fuel pump kicks on for 5-10 seconds with the key on, then turns off. OR at least some relay does. but not the pump. unpluged the pump and went to the 3 wires and when i turn the key on i get 10.5v across one green and one brown. Locked up fuel pump?
As @unslow1 says , also when you checked the voltage at the pump harness side was the voltage for a second or so then disappear or did it stay on , with your charger going south and the battery also, does sound like a surge somewhere, check that Green earth wire from the pump through connections, its happened to be that before, heres the circuit to follow,with relays and fuses
 

Attachments

·
Premium Member
Joined
·
2,615 Posts
the voltage stays on continiously. Both relays are clicking on when i turn the key on.
Hi , you really need to isolate the situation, as @unslow1 says , run a direct feed from a battery to the fuel pump, unclip the fuel line ( as per manual) remember its under pressure, get something to catch the fuel and connect the feed, if the pump runs then the fault has to be somewhere in between the battery and the pump, if the pump doesn't run .......Page 5-57 of the manual
 

·
Heeza Y Zasch
Joined
·
3,033 Posts
Okay thanks. I am getting a FI light on my gauges intermittently now to.
are you knowledgeable of how to perform the Self-Diagnosis Test and decypher the "codes" :idunno: :deal:
 
  • Like
Reactions: MrPickwick

·
Registered
Joined
·
247 Posts
Discussion Starter #15
Im wondering if it isnt varnashed up. I let the bike sit 4-5 months with very little fuel in it. I forgot to fill it up before winter hit.
 
1 - 15 of 15 Posts
Top