Honda Motorcycles - FireBlades.org banner
1 - 15 of 15 Posts

·
Registered
Joined
·
434 Posts
Discussion Starter · #1 ·
I know several riders have changed out their stock CBR900 gauges for CBR600 F4I gauges but I was unable to find any real posts from start to finish including wiring diagrams, photos, list of parts required or step by step instructions on how to do this swap. I am currently finishing up this mod on my bike. I was wondering if anyone would be interested in a full write up on the mod from start to finish. If so post here and I will get started on it.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #3 ·
There are a few differences between the the 98-99 and 96-97. The 98-99 plugs for the electrical running to the gauges don't match the plugs on the CBR F4I gauges so you have to cut and splice wires to make the swap. The 96-97 and maybe even earlier models have the same connectors as the CBR F4I and all you have to do is remove the pins from the connectors with a small screw driver and put them in the proper order to get the gauges to work. There are a few other differences that you can find if you look up posts by Sime. He was the original member I believe to do this mod and there is a thread on how he did it but it is several pages long and lacks any real photos or exact wiring diagrams.
 

·
Registered
Joined
·
32 Posts
I've done this mod on my 97 blade about a month ago, but still can't find out why my speedo doesn't work. I depinned the original cannon plugs and followed Sime's write up and a wiring diagram for both the bike and gauges. The only thing I can think of is I don't have it grounded correctly, but I did connect both grounds from the bike to the single ground of the gauges and still no go. Any suggestions would be great. Did you have to use a speedo healer? And yes I think a write up would be great.
 

·
Registered
Joined
·
434 Posts
Discussion Starter · #7 ·
I've done this mod on my 97 blade about a month ago, but still can't find out why my speedo doesn't work. I depinned the original cannon plugs and followed Sime's write up and a wiring diagram for both the bike and gauges. The only thing I can think of is I don't have it grounded correctly, but I did connect both grounds from the bike to the single ground of the gauges and still no go. Any suggestions would be great. Did you have to use a speedo healer? And yes I think a write up would be great.

Yes you have to use a speedo healer that's the reason it's not working for u
 

·
Registered
Joined
·
28 Posts
I know several riders have changed out their stock CBR900 gauges for CBR600 F4I gauges but I was unable to find any real posts from start to finish including wiring diagrams, photos, list of parts required or step by step instructions on how to do this swap. I am currently finishing up this mod on my bike. I was wondering if anyone would be interested in a full write up on the mod from start to finish. If so post here and I will get started on it.
I would also love a write up. I have a '98 and have very recently been looking at what it takes to do a mod like this. I'm excited now. :smilebig:
 

·
President: Team Full Chat
Joined
·
8,387 Posts

·
Registered
Joined
·
541 Posts
Given many riders still wish to do this mod, a fresh write up won't hurt.

A number of guys have done this mod so there are write ups "hidden" within build posts..

Check out Lambchops build thread, or Sime's build thread... To suggest a few....I am sure that there are posts within these that either tell you how, or link to, appropriate drawings...

If you have the time, I am sure a how to would be appreciated (I myself have the parts waiting to do this mod)...
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top