Honda Motorcycles - FireBlades.org banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok first let me say that thank god i found you guys and thanks to mods for page. and second i hope you can help with a bug on battery drain.

I have a 94 900 and have recently put in a new stator and a new recitifier and battery trying to chase down starting problem/charging problem. so let me give you the run down.

many months ago the bike died on me in parking lot like it has before when the recifier would take a crap. so i bought a new one and installed it and it fired right up. only to die on me cause battery took a crap. so i took bike home and metered the stator and found that it was bad (followed manual and looked on here for how to test). so i relplaced that as well this however was a few months later cause as we all know these days money was tight. so the bike had been sitting and i did not know about battery drain so i killed the battery and had to replace that again. so now i have a new battery new rectifier and new stator on bike and im getting a pretty big battery drain.

now to try and narrow this down i have disconnected the recitifier and did battery drain test and it showed nothing but if i have it hooked up it drains. so i then moved on to main starter relay and when i disconnect that it again shows no drain. When i disconnect the relay the rectifier is connected up again. i had read on here of the infamous problems with rectifiers going bad and i tried to cure problem with a suggestion on here about grounding recitifier straight to frame as opposed to that rats nest honda calls a ground system. so my question is, is it possible that i have a bad relay starter switch or headlight switch. the reason i ask this is because if you follow wires from relay they go to these various switches and realys. however when i disconnect them the drain still exists. any help would be great!!! i want to get fixed as bike week is coming next month.


thanks again

chris
 

·
Premium Member
Joined
·
9,082 Posts
first.......:welcome:

and how quickly is the battery draining?


&.. it sounds like its draining when Anything is hooked up...... I'd suggest looking for a common circuit that would affect everything first.. like the ignition switch

but others may have some other ideas for you:D
 

·
Premium Member
Joined
·
9,082 Posts
:hmm: would still look at the ignition... if it's draining that quickly even when switched off, I'm guessing it might not be shutting of properly... bad wire/connection??

think I'd try disconecting it at the harness block and see if it drains then...

but I got no real answer except tracing and checking everything methodicaly:idunno:

but the BUMP may bring an Idea* or Two

*I can't be the only one on here today
 

·
Registered
Joined
·
38 Posts
Is the battery draining to dead from a full charge, without the key in?

Are any lights running without ignition switch on?
 
1 - 5 of 5 Posts
Top