Honda Motorcycles - FireBlades.org banner
1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
i have a gtx9 battery in my cbr929. i heard there was a conversion to a gtx10 battery. in my manual it have a gtx9 battery. in the online manual it says upgraded to a gtx10. i asked my local service department they said it was a gtx10. i bought a gtx10 battery and its way too tall for the spot. the gtx9 works and does the trick. but the lights dim when in idle or at a stop light. and now its starting to just die on trips less than 3 miles or 15 minutes. can someone guide me to the right solution.
 

·
Registered
Joined
·
80 Posts
It should be a YTZ10S, maybe your local dealer is smoking bad stuff? (yes, I work for as dealer - have an SP-1 and 02 Blade my garage as I type this)

Once started the bike should be fine if the charging system is correctly operating. My SP will work just fine off a dainty little YTZ7S (stock is YTZ12S).

You may have a loose/dirty connection, stator laying down, or even a bad regulator. Have someone qualified check that thing out! :thumb:
 

·
Premium Member
Joined
·
32,104 Posts
i have a gtx9 battery in my cbr929. i heard there was a conversion to a gtx10 battery. in my manual it have a gtx9 battery. in the online manual it says upgraded to a gtx10. i asked my local service department they said it was a gtx10. i bought a gtx10 battery and its way too tall for the spot. the gtx9 works and does the trick. but the lights dim when in idle or at a stop light. and now its starting to just die on trips less than 3 miles or 15 minutes. can someone guide me to the right solution.
My guess is you are trying to replace the battery to fix a problem that probably isn't the battery at all.
Check the charging system first whenever you have electrical problems on a Honda.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top