Honda Motorcycles - FireBlades.org banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
hi can anyone help came off my blade and cracked the generator case after a month or so replaced it and filled up with clean oil recharged the battery as it was flat went to start it nothing but a clicking sound from the battery housing well the relay switch she ran when i bumped started her left her to run for a while turned her off then tried to start her with the electric start same problem clicking sound have checked most of the connections and are all nice and tight help!!!!!!!!!!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
hi did not damage the battery when i came off
was only going about 10 mph at the time mushrooms took all the impact
picked her up and she started straight away with the electric start its since i have changed the generator cover i did no work on it for about a month and a bit it just sat in the garage with the generator cover off until i got the new one
 

·
Registered
Joined
·
10 Posts
I know this may sound simple try charging your battery fully. If the Bat is not completely charged the bike will just click. I had a simlier problem w/ my 954rr
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
hi will try that i am using a optimate 3 charger will leave it charging all day see what happens watch this space
 

·
Registered
Joined
·
71 Posts
If some cells got dammaged during the time it was flat it may not take full charge anymore. Also remember that it may be a few years old in any case, so even if you charge it until next year it will not get fully charged-even if the charger switches off outomatically. The moment you hit the button the solenoid kicks in (the click) and thats it, not enough juice to turn it over. Take the battery to someone selling them and let them check it over (they have ways to see if it still takes a charge). If not buy a new one.

Something else that is important is that if it got discharged during only a month of inactivity there might be a short somewhere draining your battery, and it will kill the new one too..so I would check on that if I were you.
 

·
Registered
Joined
·
1,387 Posts
sounds likely to be the battery, but have a quick check that the battery connections are done up properly and on the starter motor to check wires are all tight, same on the solanoid/relay thats clicking. just my 2c
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
big thank you to all advice:clap: but was a different problem alltogether i had not put back a locating pin which holds a cog from the starter motor to the main fly wheel :huh: what a dick i am :nono: anyway now sorted and back on the road shame about the weather :thumbd: :thumbd: :thumbd: bring on the summer:thumb: :thumb: :thumb: :thumb:
 
1 - 11 of 11 Posts
Top