Honda Motorcycles - FireBlades.org banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi im new to the forum. i recently got my frame powder coated and put back togather. now i have a problem. my cluster wont work. i tried switching it out with a new one and didnt help.fuse is good, battery is charged. the backlight is working, turn signels, hi beam and netural is working. no tach, no speedo, no clock, no heat, no oil light. please someone help me. thanks corey
 

·
Super Moderator
Joined
·
32,034 Posts
hi im new to the forum. i recently got my frame powder coated and put back togather. now i have a problem. my cluster wont work. i tried switching it out with a new one and didnt help.fuse is good, battery is charged. the backlight is working, turn signels, hi beam and netural is working. no tach, no speedo, no clock, no heat, no oil light. please someone help me. thanks corey

Have you put the ECU in the bike?
 

·
Registered
Joined
·
94 Posts
I would say double check your fuses? Idk if 929 and 954 have the same fuse order but it should be the first(Towards front of bike) 10 amp swap it out and see if that helps. Just a suggestion because I had the same issue and it was just the fuse. :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I would say double check your fuses? Idk if 929 and 954 have the same fuse order but it should be the first(Towards front of bike) 10 amp swap it out and see if that helps. Just a suggestion because I had the same issue and it was just the fuse. :)
thanks for the advise, but i changed all of them with brand new ones. still nothing. i really dont get it. is there any grounds im missing? all i see is the negitive that goes from battery to engine and 2 wires to the frame by the battery. is there any more?
 

·
Registered
Joined
·
94 Posts
The two main ground places that I know about are the battery and also the frame right in front of the battery. I would say get a wiring diagram for the 929 and start tracing wires and you can find your ground and everything possible of causing the issue.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
The two main ground places that I know about are the battery and also the frame right in front of the battery. I would say get a wiring diagram for the 929 and start tracing wires and you can find your ground and everything possible of causing the issue.
i looked at both, both are good. im stumped, anyone else have any ideas?
 
1 - 7 of 7 Posts
Top