Honda Motorcycles - FireBlades.org banner

1 - 11 of 11 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Replaced motor last summer. Installed and now is starts cold runs choppy then pulls ck engine and FI code and idles up a bit and runs fine 5 seconds after starting. It pulls no diagnostic codes. I have Haynes Manual and it’s says bad ECU. Does anyone have any experience. Used ECUs are fairly cheap so I’m not worried about cost. Thanks
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
When I put it back together I actually took air box back off and checked everything tightened up injection manifold boots which were a bit loose thought maybe that was it. I’ll be taking the tank off to have painted so I’ll recheck everything again. It doesn’t go thru diagnostic mode they just come on after 5 seconds.
 

·
Premium Member
Joined
·
2,712 Posts
Is there no lights on the panel when you switch on and pump primes, when your air box is off check all your connectors to the Instrument panel
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
No lights when turning key on. They come on after starting and running for 5 seconds then motor idles up a bit and seems to run fine.
 

·
Premium Member
Joined
·
2,712 Posts
When you turn on and before you press the start button does the horn work, just trying to find out if you have some loose wires
 

·
Registered
Joined
·
26 Posts
Discussion Starter #9
Can’t get fault codes because doesn’t run thru diagnostic process ck engine and FI light just come on and stay on. Haynes manual say it’s either loose/bad connection or bad ECU.
 

·
Premium Member
Joined
·
2,712 Posts
Have you had a look at the service check wire and see if its being shorted with a jumper wire, if it hasn't try going through the system to find fault codes, a short in that service check wire will give you the problem you have at present
 

·
Registered
Joined
·
1,552 Posts
The malfunction indicator lamp (MIL) will start blinking only with the side stand down and with the engine off (engine stop switch in RUN) or engine revs are below 5, 000 rpm.
In any other conditions, the malfunction indicator lamp (MIL) will illuminate and stay on.
SELF-DIAGNOSTIC PROCEDURES
Place the motorcycle on its side stand . Start the engine and let it idle .
If the malfunction indicator lamp (MIL) does not light or blink, the system has no memory of problem data .
If the malfunction indicator blinks, note how many times the malfunction indicator lamp (MIL) blinks, and determine the cause of the problem.
If you wish to read the PGM-FI memory for trouble data, perform the following :
IGNITION SWITCH
Turn the ignition switch OFF.
Remove the seat.
Short the PGM-Fl system service check connector terminals using a jumper wire.

Turn the ignition switch ON and engine stop switch RUN.
If the ECM has no self diagnosis memory data, the MIL will illuminate when you turn the ignition switch ON.
If the ECM has self diagnosis memory data, the MIL will start blinking when you turn the ignition switch ON .
Note how many times the MIL blinks, and determine the cause of the problem
 
1 - 11 of 11 Posts
Top