Honda Motorcycles - FireBlades.org banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
so i run the crap out of the bike for a good high speed run and the oil light comes on 10-20 mi distance guy told me i am thinning out the oil due to temp but im using repsol racing oil and change it all the time last changed 2 weeks agao happend on sunday again the bike is an 2002 cbr 954 7k mi is there oil pump issues on this bike or does any body have any suggestions on whats going on?:idunno:
 

·
Registered
Joined
·
1,628 Posts
maybe a bad sensor......
 

·
Registered
Joined
·
552 Posts
are you usuing the cossect weight oil, how does the engine sound when you see the light on. if you are usuing the correct oil and you dont have any unusal noises then you most likly have a sensor going bad or a poor connection at the sensor.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
the engine sounds good and the light goes off if i let it cool down and im runnin 10-40 ill look for loose connection at the sencer

thanks for the tips ill let you know what i find
 

·
Super Moderator
Joined
·
32,034 Posts
so i run the crap out of the bike for a good high speed run and the oil light comes on 10-20 mi distance guy told me i am thinning out the oil due to temp but im using repsol racing oil and change it all the time last changed 2 weeks agao happend on sunday again the bike is an 2002 cbr 954 7k mi is there oil pump issues on this bike or does any body have any suggestions on whats going on?:idunno:
I assume you have checked the oil level and it's okay?
Do an oil pressure test.
 

·
Registered
Joined
·
23 Posts
happened 2 me after a fresh oil change.

2 miles late i stop to eat

10 minutes later i get on the bike, oil light comes on but when i rev-ed it went off so i assumed it was making pressure, jump on the freeway and hit the rev-limiter....KABAM!

opened her up, crankshaft is toast. oil starved.

$1,000 in the hole.

be careful.
 

·
Super Moderator
Joined
·
32,034 Posts
Loss of oil pressure when oil gets hot is, to my simple mind, a clear indication of bearings going.
Damage to the bearings is certainly likely if the pressure is low.
Having changed the oil just two weeks ago could indicate something wrong as a result of that. Not enough oil or a blocked filter would be the obvious ones. Low oil volume though would generally be fine at low revs and cause the light to come on at higher revs.
The only way to be sure the bearings are okay is to check the oil pressure.
When the oil was changed was the engine run at all before the new oil was put in? A compression test maybe?
 
1 - 8 of 8 Posts
Top