Honda Motorcycles - FireBlades.org banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi I'm ghys, first time on this forum, two problems, first while driving yesterday the bike stalled but within seconds it started again, on this forum some say to check the fuel pump ground, the on/off switch, maf sensor or the rectifier. If it's the rectifier what do you guys usually replace it with oem or aftermarket?

Problem 2, under hard acceleration bike puff some black smoke, plug where changed last august and have about 3000-4000 km on them, last year one plug went bad, at that time the black smoke was there. Since then the cam chain tensioner was replace and the throttle bodies we're adjusted, and still black smoke come out!

Bike has 29000km. Any hint on what i should look at Will be appreciated.

Thank you
 

·
Registered
Joined
·
4,132 Posts
/sigh see post on tech support all over again.....
 

·
Super Moderator
Joined
·
32,034 Posts
Hi I'm ghys, first time on this forum, two problems, first while driving yesterday the bike stalled but within seconds it started again, on this forum some say to check the fuel pump ground, the on/off switch, maf sensor or the rectifier. If it's the rectifier what do you guys usually replace it with oem or aftermarket?

Problem 2, under hard acceleration bike puff some black smoke, plug where changed last august and have about 3000-4000 km on them, last year one plug went bad, at that time the black smoke was there. Since then the cam chain tensioner was replace and the throttle bodies we're adjusted, and still black smoke come out!

Bike has 29000km. Any hint on what i should look at Will be appreciated.

Thank you

Start with checking the fuel pressure regulator vacuum hose is dry.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
The bike start without problem, it stalled while driving and while slowing down on compression it started by itself and kept running. It happened twice on a 300km drive. Outside temperature was 38℃ very humid but the bike temps was running around 85-95℃.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Hi guys, went out today and start checking what was wrong with the bike, found part of the problem. First off this morning bike wouldn't start, fuel pump was not priming itselft, no power at the harness. Turn out that right in front of the battery where à bunch of connector are, there is a yellow one with a bunch of green wire that was melted! Managed to fix it and now it work!

Now i'm kind of curious as of why it happened?
 

·
Super Moderator
Joined
·
32,034 Posts
Hi guys, went out today and start checking what was wrong with the bike, found part of the problem. First off this morning bike wouldn't start, fuel pump was not priming itselft, no power at the harness. Turn out that right in front of the battery where à bunch of connector are, there is a yellow one with a bunch of green wire that was melted! Managed to fix it and now it work!

Now i'm kind of curious as of why it happened?

This is a fairly common problem on the 929/954.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
Bladeracer do you know what causes that? Do people usualy do a quick fix like I did or they replace the entire harness?

Thank again for all the help.
 

·
Super Moderator
Joined
·
32,034 Posts
Bladeracer do you know what causes that? Do people usualy do a quick fix like I did or they replace the entire harness?

Thank again for all the help.

No idea, electrics are magic to me :)
Usually just a matter of cleaning the wires, soldering them all together and taping it up again.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
So went out and tried the bike, maybe it's just me but it felt more responsive under hard acceleration, dont know if it was smokin black but on neutral when giving hard gas it was smoking a lot less. I think this is due to the fact that someone before me remove the pump and put the pump bracket on the wrong side making the return fuel line stretch and pinched making it hard for good circulation. The fuel regulator was dry so no leasing there.

Like to thank everyone who gave me some hint on where to start.
 
1 - 13 of 13 Posts
Top