Honda Motorcycles - FireBlades.org banner

21 - 31 of 31 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #21 (Edited)
mm interesting , your theory sounds do-able ... ill give it a go

ok just got back ...Nope no way is this going to fit and I'm buggered as to why . I have taken some shots of it fitted as per above directions , I almost had a glimmer of inspiration ..... almost.... but as you will see in the following pictures even when fitted up there is no way this cable will reach, with or without the lever removed from its perch. not sure thinking it may have to go to the workshop to figure out but don't like my chances of a quick fix ....#@&* !!
 

·
President: Team Full Chat
Joined
·
8,183 Posts
M
ok here's the pics , cant but think this cable is just too short .... it just doesn't fit . will take it back to the dealer who sold it and will explore options for letting a workshop inspect
By the look of the last picture, the clutch lifter is def too far to the rear of the bike. And the cable does look a bit off. Pull the cover again and make sure the internal pieces are in right. Especially this piece, it should not be able to be pulled out:

 

·
Registered
Joined
·
23 Posts
Discussion Starter #24
yep will do , Ian did inspect that piece pictured above , and no it defiantly wont come out, although it does slide easily 5-10mm back and forth. I tried several times when refitting the clutch cover to get the lift linkage to sit more 12 o'clock position instead of the 930 position but it really only fits in one spot and one spot only.
Never mind will have another look later in the week.
Your enthusiasm and assistance has been absolutely fantastic with this , I understand It can be quite difficult to help over the internet , but rest assured you guidance has been very much appreciated by me , Thankyou.
will continue to unravel this mystery
 

·
President: Team Full Chat
Joined
·
8,183 Posts
Hey Jim, I just happened to be watching a YouTube video of a 600 F2 walk around. Saw a good shot of his clutch cable, and I must say it looked like the one you had. I would imagine the 600's would be similar (they too had the 90 degree bend by the lever) but shorter. Maybe that's the one you got? :idunno:
 

·
Registered
Joined
·
23 Posts
Discussion Starter #26 (Edited)
Wow ... um the moons have aligned or something like that ... um here goes....
Got home ,grab a beer .head out to the bike on stands... though I might go out and just run her to keep the battery healthy, I love the sound plus the weekends events still have me stumped.....
Fire her up , no clutch cable fitted off the ground just chuck her in gear and run it up a bit.... well quick sprint no too much as its cold 1.2.3.4.5 .... 140kmh and back down idle then stop. Agh beautiful .....just one more look at why this clutch lifting lever is in the wrong position... everything's back where it should be WTF ... how ...don't know it was defiantly jammed before... go figure
well I don't know how or why but its unjammed , although worst part is it has to come off again as I damaged the cover gasket inspecting it before .... but hey atleast I know it does go where it should.
Big thanks Ian for persisting with diagnosing my problem, very much appreciated.
Oh I reckon she may have just saved an early retirement :)

Just on this I can only think that maybe something wasn't aligned or something and that "grabbing a few gears" without any load or clutching mechanism has somehow freed whatever was causing this... only hope that if what I had and done can possibly help someone down the track with similar issues.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #27
Re cable , Could be, I did return that cable to the dealer ..... "bad attitude dealership" they were very arrogant and determined to tell me I'm wrong and that that I must be doing it wrong and that I didn't know what I was doing .... excuse me what's that sound .....oh its me walking away with my wallet never to return.
I can admit I don't know when things don't go right but that's why I ask ... sorry for the rant , going off topic
However I will take the bike down on a trailer to another smaller business that said they were more than happy to have a look and test fit it for free , no probs. agh that's where ill spend my money , thankyou
 

·
President: Team Full Chat
Joined
·
8,183 Posts
That's my mission in life, saving CBR 900's 1 at a time. :thumb: Hope you get confirmation that's it's good to go with the new cable. Repost when you know the outcome. I love the "fixed but I don't know why" experiences. Well done and good luck with it.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #29
Thankyou you have defiantly saved this one ,
One last quick question on clutch cover gaskets are they the same , I have looked over the net and found that the same gasket covers fits 93 thru to 99
HONDA 93-99 CBR 900 RR CLUTCH COVER GASKET HM-305
does this go for the clutch cover type you have and the one I have with the oil level window?? do they use the same gasket
thanks
 

·
President: Team Full Chat
Joined
·
8,183 Posts
Thankyou you have defiantly saved this one ,
One last quick question on clutch cover gaskets are they the same , I have looked over the net and found that the same gasket covers fits 93 thru to 99
HONDA 93-99 CBR 900 RR CLUTCH COVER GASKET HM-305
does this go for the clutch cover type you have and the one I have with the oil level window?? do they use the same gasket
thanks
Yes, same gasket all years 92-99.
 
21 - 31 of 31 Posts
Top