Honda Motorcycles - FireBlades.org banner

1 - 5 of 5 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
hey all I just installed some shorty levers on my 900rr 97 model love them so far but since installing my clutch slips I didn't mess with any adjustment at all just put them in could they be causing my clutch to slip in any way possible
 

·
Premium Member
Joined
·
32,034 Posts
hey all I just installed some shorty levers on my 900rr 97 model love them so far but since installing my clutch slips I didn't mess with any adjustment at all just put them in could they be causing my clutch to slip in any way possible

Try adjusting the cable.
Simple way to know is to put the OEM lever back on.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
I figured out why its slipping but don't know how to remedy it the lever is not returning fully leaving a quarter inch or so between the lever and clip on if I push it to rest it doesn't slip but I don't know why it won't rest fully the oem never did this
 

·
Registered
Joined
·
3,890 Posts
Did you clean the housing and use some white lithium grease to lube the new lever? Have you tried adjusting the cable yet?
 

·
Registered
Joined
·
3,226 Posts
I figured out why its slipping but don't know how to remedy it the lever is not returning fully leaving a quarter inch or so between the lever and clip on if I push it to rest it doesn't slip but I don't know why it won't rest fully the oem never did this
Disconnect the cable and see if the lever moves freely in the housing, if it does proceed like BR and Sky said. Definitely make sure the housing is clean and put a little grease on it. If it doesn't, find out why. might have to do a little work with a fine file.
 
1 - 5 of 5 Posts
Top