Honda Motorcycles - FireBlades.org banner
1 - 4 of 4 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
Under hard acceleration sitting on the stand or while ridding, the bike dies.
The HESD light comes on the the fuel pump will not prime until i turn the switch off and back on again.
The bike was parked for a few months for powder coating over the winter. I, being an idiot didn't empty the tank.
I put the bike back together, i did install new iridium plugs, oil and air filters.
I've ran out the gas that was inside the tank and 2 other tanks of gas. I used sea foam after each fill up.
I've removed the tank and emptied the gas, Removed the fuel pump and i'm going to clean it tomorrow,removed the plugs which appear to be ok-maybe a little rich. Because i was already that far into the process, i popped off the valve cover and checked the timing which also seems to be spot on!
Is there anything else i should check while i have the bike apart besides cleaning the tank and fuel pump?
Is there a way i can clean the injectors from home?
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #2 ·
Also, under 5k when holding the throttle steady, the RPM's seem to fluctuate WAY to much. For instance if i'm holding at 2500, the RPM's will drop to between 2200 and 2800 and you can hear this via the exhaust.
 

·
Banned
Joined
·
474 Posts
I'd find something that gunk would make for injectors and ratio that out in the tank, or chevron techroline. You ratio somewhat over a touch and just keep riding it. I'm thinking a sitter and varnish or something sticking (rich) an injector open ie, the code comes on is the injector is tied in with pump?

HESD? Let me guess. Has Entered Single Digit. Jk. That's an inside joke.

So no codes, right? Just sat. Starts, runs up to redline. Just a couple of key turns and the pump comes back on, no hard code reset once you cycled the key. That's more how I say no set hard code. Say yes, no codes after key turn cycle, then dirty injectors is taken by a grain of salt I start guessing at it.
 

·
Banned
Joined
·
474 Posts
Under hard acceleration sitting on the stand or while ridding, the bike dies.
The HESD light comes on the the fuel pump will not prime until i turn the switch off and back on again.
I'd now disconnect the HESD and look for green at the male/female pins.
I'd go down the the speed sensor at the front sprocket area and see if that connector at the harness is green with a chemical reaction of years getting on with this baby.

As I have both connectors off, I now test ride, static snap the throttle and see if there is a fueling problem still. I have the electronic steering damper as being tied in with the fueling and wheel speed.
 
1 - 4 of 4 Posts
Top