Honda Motorcycles - FireBlades.org banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi, I am new to forums and motorcycle repair and could use a little advice :)

I have an 01 600 F4i that i purchased running a couple weeks back... It ran for a day, then died as i was down shifting, approaching a stoplight. Hasn't started since then. I have replaced the starter switch, battery, and kickstand switch, but also found a rouge wire screwed into my ecm, which was removed... I fear i need a new ecm and if so i would purchase one if you have one available.

I cant figure out why it would just die out of the blue and not fire back up.
If anyone has the time to troubleshoot with me i would be grateful.

If anyone has a spare 01 ecm, shoot me an email @ [email protected]

Thanks!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Re: Electrical issues, need tps

eBay when you can't get one from another blade rider here

Ok update, It turns out my fuse for my bas was shot, i replaced that and my bike started to turn over, fuel pump is priming. MIL indicates that i have a faulty throttle position sensor.

Progress... :)


I am currently looking for a tp sensor for my 01 f4i

Any help would be much appreciated, thanks
 

·
Registered
Joined
·
23 Posts
I think i might have a similer problem with my 01 f4i. The bike will start with help, (starting fluid) and will idle all day ,but when i hit the throttle it dies. i have replaced everything and need help.
 
1 - 4 of 4 Posts
Top