Honda Motorcycles - FireBlades.org banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i am having a similar problem fi light stays on tho and and...
I have a 03 CBR 954... here comes the fun part. i recently droped the motor out of the frame to have it welded. prior to doing this the bike ran like a champ had good throttle reaction, good idle, no problems... motor sat for about two weeks. after putting everything back together now the bike boggs and gurrgles @ about 3/4 throtttle in every gear... also when given a quick throttle input it either boggs or dies all together. the bike does well with slow increase in throttle while sitting and riding but once you get on the throttle it jerks around and the motor bogs real bad. the bike is running super rich backfiring a little and kicking out black smoke with throttle input. i removed the plugs before and they were fouled however i cleaned them up and re-installed the same ones. i am getting ready to just buy all new plugs but trying to avoid that @ $21 per plug. i have also pulled the line of the backside of the fuel pressure regulator on the fuel rail. no drips nothing. pulled the fuel rail off and looked at the injectors the only find i had there was the number 1 injector had the o-ring ripped not only the one that was on the injector but also the one that it sat in were both ripped and or gone... the rest of the injectors looked good... DOES ANY ONE HAVE ANY MORE ADVICE THAT COULD HELP ME GET BACK ON THE ROAD
 
1 - 1 of 1 Posts
Top